Closed Bug 1374498 Opened 5 years ago Closed 1 year ago

Facebook popup is being blocked on sites like coursera.org

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1733052
Webcompat Priority ?

People

(Reporter: bmo, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Name: 	  Firefox
Version:  56.0a1
Build ID: 20170619030208

Logs appeared in Web Console shown that certain scripts were blocked by TP.

The resource at “https://connect.facebook.net/en/sdk.js” was blocked because tracking protection is enabled.[Learn More] ntumlone-mathematicalfoundations
Loading failed for the <script> with source “https://connect.facebook.net/en/sdk.js”. ntumlone-mathematicalfoundations:1
The resource at “https://platform.twitter.com/widgets.js” was blocked because tracking protection is enabled.[Learn More] ntumlone-mathematicalfoundations
Loading failed for the <script> with source “https://platform.twitter.com/widgets.js”.

ER: When enabled TP and scripts are blocked by TP, it should show an UI notification to users.

AR: No response and interaction when press the log in button. Just felt the site is broken.
Blocks: tp-breakage
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226498
Blocks: tplogin
No longer blocks: tp-breakage

This should be fixed now that we have a shim to allow Facebook popups using SmartBlock, but the popup is being blocked even outside of Strict mode ETP.

Yet this doesn't happen in Chrome; the popup is allowed and I'm not sure why. If I set a logpoint in the FB SDK's popup function, just where it's calling window.open, window.event is undefined in both browsers. Perhaps the user-activation requirements are just relaxed in Chrome by comparison?

Edgar, I think you were involved in user activation model stuff. Would you have any ideas on how to diagnose this further?

Status: RESOLVED → REOPENED
Flags: needinfo?(echen)
Resolution: DUPLICATE → ---
Blocks: 1657930
No longer blocks: tplogin
See Also: → 1639809
Summary: [Tracking Protection] Unable to log in coursera.org with Facebook account → Facebook popup is being blocked on sites like coursera.org

(In reply to Thomas Wisniewski [:twisniewski] from comment #2)

Edgar, I think you were involved in user activation model stuff. Would you have any ideas on how to diagnose this further?

Currently, user activation for popup blocker doesn't support tracking through the callbacks, maybe the webpage calls window.open asynchronously, something like call it in setTimeout callback or such?

Flags: needinfo?(echen)

Yeah, that should account for the breakage here. Do we have any bugs on file for fixing it?

Are other browsers using user activation (vs gesture) for popups? If we want to use it we should make sure that window.open consumes activation.

Component: Protections UI → DOM: Core & HTML
Product: Firefox → Core
Webcompat Priority: --- → ?
Depends on: 1656444
Status: REOPENED → RESOLVED
Closed: 5 years ago1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1733052
You need to log in before you can comment on or make changes to this bug.