Closed Bug 1374572 Opened 3 years ago Closed 2 years ago

Crash in java.lang.NullPointerException: Attempt to invoke interface method ''android.os.IBinder org.mozilla.gecko.media.IMediaManager.asBinder()'' on a null object reference at org.mozilla.gecko.media.RemoteManager.release(RemoteManager.java)

Categories

(Firefox for Android :: Audio/Video, defect, P1, critical)

54 Branch
Unspecified
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 56
Tracking Status
fennec + ---
firefox54 --- wontfix
firefox55 --- fixed
firefox56 --- fixed

People

(Reporter: gchang, Assigned: jhlin)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-142fbe5e-be67-4254-a5f8-94e9d0170619.
=============================================================
Frame 	Module 	Signature 	Source
0 	libxul.so 	mozilla::java::CodecProxy::Release 	widget/android/jni/Accessors.h:59
1 	libxul.so 	mozilla::RemoteDataDecoder::ProcessShutdown 	dom/media/platforms/android/RemoteDataDecoder.cpp:568
2 	libxul.so 	mozilla::detail::ProxyRunnable<mozilla::MozPromise<bool, bool, false>, RefPtr<mozilla::MozPromise<bool, bool, false> > (mozilla::MediaDecoderReader::*)(), mozilla::MediaDecoderReader>::Run 	xpcom/threads/nsThreadUtils.h:855
3 	libxul.so 	mozilla::TaskQueue::Runner::Run 	xpcom/threads/TaskQueue.cpp:232
4 	libxul.so 	nsThreadPool::Run 	xpcom/threads/nsThreadPool.cpp:225
5 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:1264
6 	libxul.so 	NS_ProcessNextEvent 	xpcom/threads/nsThreadUtils.cpp:389
7 	libxul.so 	mozilla::ipc::MessagePumpForNonMainThreads::Run 	ipc/glue/MessagePump.cpp:368
8 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:231
9 	libxul.so 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:495
10 	libnss3.so 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c:216
Ø 11 	libc.so 	libc.so@0x40643 	
Ø 12 	libc.so 	libc.so@0x40623 	
Ø 13 	libc.so 	libc.so@0x40623 	
Ø 14 	libc.so 	libc.so@0x1a021 	
15 	libnss3.so 	_PR_CreateThread 	nsprpub/pr/src/pthreads/ptthread.c:541

This is #23 topcrash for firefox for android and there is a spike in the last 3 days.
Sebastian can you help find someone to look at this?  It spiked after the 54 release and is still present in 55beta.
Flags: needinfo?(s.kaspari)
Setting triage flag for the mobile core browser team.

@alastor: It's in the media code - is this something you can look into?
tracking-fennec: --- → ?
Flags: needinfo?(s.kaspari) → needinfo?(alwu)
It looks like related to OOP decoding, so lets forward to jhlin.
Component: General → Audio/Video
Flags: needinfo?(alwu) → needinfo?(jolin)
Priority: -- → P1
It's caused by a bug that the remote link is not protected properly and when decoder shutting down at the same time remote process is dying, which is handled later will get NPE.
Flags: needinfo?(jolin)
Assignee: nobody → jolin
tracking-fennec: ? → +
[traige@0719] + as taken by Media team already with P1.
Comment on attachment 8887814 [details]
Bug 1374572 - don't access disconnected remote binder.

https://reviewboard.mozilla.org/r/158724/#review164126
Attachment #8887814 - Flags: review?(esawin) → review+
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ec985416f30
don't access disconnected remote binder. r=esawin
https://hg.mozilla.org/mozilla-central/rev/1ec985416f30
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Duplicate of this bug: 1374578
Please request Beta approval on this when you get a chance.
Flags: needinfo?(jolin)
Comment on attachment 8887814 [details]
Bug 1374572 - don't access disconnected remote binder.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1257777
[User impact if declined]: browser crashes when remote process crash and decoder shutting down at the same time
[Is this code covered by automated tests?]:no
[Has the fix been verified in Nightly?]:yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]:none
[Is the change risky?]:low risk
[Why is the change risky/not risky?]:it protects data access from multiple threads
[String changes made/needed]:none
Flags: needinfo?(jolin)
Attachment #8887814 - Flags: approval-mozilla-beta?
Comment on attachment 8887814 [details]
Bug 1374572 - don't access disconnected remote binder.

fennec crash fix, beta55+
Attachment #8887814 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.