Crash in java.lang.NullPointerException: at org.mozilla.gecko.media.RemoteManager.release(RemoteManager.java)

RESOLVED DUPLICATE of bug 1374572

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 1374572
6 months ago
5 months ago

People

(Reporter: gchang, Unassigned)

Tracking

({crash})

54 Branch
Unspecified
Android
crash
Points:
---

Firefox Tracking Flags

(firefox54 affected, firefox55 affected, firefox56 ?)

Details

(crash signature)

(Reporter)

Description

6 months ago
This bug was filed from the Socorro interface and is 
report bp-0fab6e5a-cb0d-43f4-bd4c-ee2220170619.
=============================================================
Frame 	Module 	Signature 	Source
0 	libxul.so 	mozilla::java::CodecProxy::Release 	widget/android/jni/Accessors.h:59
1 	libxul.so 	mozilla::RemoteDataDecoder::ProcessShutdown 	dom/media/platforms/android/RemoteDataDecoder.cpp:568
2 	libxul.so 	mozilla::detail::ProxyRunnable<mozilla::MozPromise<bool, bool, false>, RefPtr<mozilla::MozPromise<bool, bool, false> > (mozilla::MediaDecoderReader::*)(), mozilla::MediaDecoderReader>::Run 	xpcom/threads/nsThreadUtils.h:855
3 	libxul.so 	mozilla::TaskQueue::Runner::Run 	xpcom/threads/TaskQueue.cpp:232
4 	libxul.so 	nsThreadPool::Run 	xpcom/threads/nsThreadPool.cpp:225
5 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:1264
6 	libxul.so 	NS_ProcessNextEvent 	xpcom/threads/nsThreadUtils.cpp:389
7 	libxul.so 	mozilla::ipc::MessagePumpForNonMainThreads::Run 	ipc/glue/MessagePump.cpp:338
8 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:231
9 	libxul.so 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:495
10 	libnss3.so 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c:216
Ø 11 	libc.so 	libc.so@0xd602

This is #36 topcrash for firefox for android and there is a spike in the last 3 days.
(Reporter)

Updated

6 months ago
status-firefox54: --- → affected
status-firefox55: --- → affected
status-firefox56: --- → ?
:jolin, could you investigate please ?
Flags: needinfo?(jolin)
This looks the same as bug 1374572. Mark as dup.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(jolin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1374572
You need to log in before you can comment on or make changes to this bug.