Closed Bug 1374610 Opened 3 years ago Closed 3 years ago

AngularJS routing does not work with production web extension `tabs.create` url

Categories

(WebExtensions :: Untriaged, defect)

54 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1328865

People

(Reporter: kyle.spearrin, Unassigned)

Details

Attachments

(1 file)

Attached image File not found.
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.104 Safari/537.36

Steps to reproduce:

Create a new tab to an AngularJs route. Ex: `chrome.tabs.create({ url: '/popup/index.html#!/tab/vault' });`

Code reference for real addon: https://github.com/bitwarden/browser/blob/master/src/popup/app/vault/vaultController.js#L158

You can also download the bitwarden addon at https://addons.mozilla.org/en-US/firefox/addon/bitwarden-password-manager/ and click the expand icon at the top of the vault page.


Actual results:

File not found page. Screenshot: http://imgur.com/gMdcCJl

The weird part is this only happens when the web extension is downloaded from the addon store. If you run the same exact code through a temporary addon in `about:debugging` it works as expected.

Linking to `chrome.tabs.create({ url: '/popup/index.html' });` works as expected and you can then navigate to additional AngularJS routes. However, if you manually refresh (F5) on a route you get file not found again.

Test cases. Enter the following in address bar with the production addon (note: GUID may change):

- Typing `moz-extension://a8c34d79-1d46-4f70-ac21-035fae7d5b02/popup/index.html#!/tab/vault` and hit enter results in file not found.
- Typing `moz-extension://a8c34d79-1d46-4f70-ac21-035fae7d5b02/popup/index.html` and hit enter works correctly. Navigate to `/popup/index.html#!/tab/vault` by clicking the link on page works. Refresh page with `F5` results in file not found.


Expected results:

Page opened in new tab an route navigated to.
Also note that this only affects Firefox. This has been tested in Chrome and all works as expected.
Status: UNCONFIRMED → NEW
Component: Untriaged → WebExtensions: Untriaged
Ever confirmed: true
Product: Firefox → Toolkit
This sounds like bug 1328865.  Can you reproduce in a recent Nightly?
Flags: needinfo?(kyle.spearrin)
I see this issue are fixed in Nightly 56.0a1 (2017-06-21).
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1328865
Flags: needinfo?(kyle.spearrin)
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.