Closed Bug 1374646 Opened 2 years ago Closed 2 years ago

3.09 - 5.23% cart (windows7-32) regression on push f26ae19477f5 (Tue Jun 20 2017)

Categories

(WebExtensions :: Frontend, defect)

defect
Not set

Tracking

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 --- fixed

People

(Reporter: igoldan, Assigned: mikedeboer)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=f26ae19477f5

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  5%  cart summary windows7-32 opt e10s     27.08 -> 28.50
  3%  cart summary windows7-32 pgo e10s     19.39 -> 19.99


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=7418

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Component: Untriaged → WebExtensions: Frontend
Depends on: 1347182, 1373320
Product: Firefox → Toolkit
Version: Trunk → unspecified
:mikedeboer Can you take a look at this regression and estimate a fix time? Looks like it's happening on windows only.
Flags: needinfo?(mdeboer)
this is happening on linux64 as well.
The backout of bug 1347182 is on autoland atm. This will - obviously - fix this regression as well.
Flags: needinfo?(mdeboer)
OS: Windows 7 → Unspecified
Thanks to Joel, I noticed this affected osx also.
Anyway, I'm confirming the backout's improvement with the 1st alert that arrived:

== Change summary for alert #7428 (as of June 20 2017 14:46 UTC) ==

Improvements:

  4%  cart summary osx-10-10 opt e10s     29.19 -> 28.06

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=7428
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Assignee: nobody → mdeboer
Target Milestone: --- → mozilla56
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.