"Restart to update Nightly" and its icon are randomly aligned

VERIFIED FIXED in Firefox 56

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: mak, Assigned: mikedeboer)

Tracking

(Blocks 1 bug)

unspecified
Firefox 56
Points:
---

Firefox Tracking Flags

(firefox56 verified)

Details

(Whiteboard: [photon-structure])

Attachments

(2 attachments)

Posted image Screenshot (8).png
See the screenshot, the icons and text should be aligned with the other entries in the menu, they appear to have their own bogus alignment.
Not sure if strictly related to the localized string length.
(Assignee)

Updated

2 years ago
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Iteration: --- → 56.1 - Jun 26
Flags: qe-verify?
Priority: -- → P1
Comment hidden (mozreview-request)

Updated

2 years ago
Duplicate of this bug: 1374598

Comment 3

2 years ago
mozreview-review
Comment on attachment 8879618 [details]
Bug 1374694 - Fix indentation and font used for multi-line labels inside panelviews.

https://reviewboard.mozilla.org/r/150962/#review156154

r=me with the comment below addressed.

::: browser/themes/shared/customizableui/panelUI.inc.css:1266
(Diff revision 1)
>  photonpanelmultiview .subviewbutton-iconic:not(.subviewbutton-back) > .toolbarbutton-text,
>  photonpanelmultiview .cui-withicon > .toolbarbutton-text,
>  photonpanelmultiview .subviewbutton[image] > .toolbarbutton-text,
>  photonpanelmultiview .subviewbutton[checked="true"] > .toolbarbutton-text,
>  photonpanelmultiview .panel-banner-item > .toolbarbutton-multiline-text {
> +  padding: 0;

We already set this for .toolbarbutton-text, right above this rule.

I think we should remove the multiline-text selector padding-inline-start from the selector for this rule, and move the padding:0 and copy padding-inline-start: 8 to the new rule you're creating to set the font with.
Attachment #8879618 - Flags: review?(gijskruitbosch+bugs) → review+
Comment hidden (mozreview-request)

Comment 5

2 years ago
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ef8aac47b513
Fix indentation and font used for multi-line labels inside panelviews. r=Gijs

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ef8aac47b513
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56

Comment 7

2 years ago
I have reproduced this bug with Nightly 56.0a1 (2017-06-20) on Windows 8.1 (64 bit).

This bug's fix is verified with Latest Nightly 56.0a1.

Build ID : 20170622030208
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170621]
Duplicate of this bug: 1376152

Updated

2 years ago
Flags: qe-verify? → qe-verify+
QA Contact: gwimberly

Comment 9

2 years ago
Verified on Windows and Ubuntu, but can't test on Mac since the update channel is broken (or so I was told yesterday).

Comment 10

2 years ago
Looks like there's a message that appears on Mac that says to "Download a Fresh Copy of Nightly" and that looks to be properly aligned. 

Marking as Verified.
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Updated

2 years ago
Blocks: 1387512
You need to log in before you can comment on or make changes to this bug.