save contents of window as group to session history when closing

RESOLVED DUPLICATE of bug 127637

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 127637
17 years ago
10 years ago

People

(Reporter: gwalla, Assigned: radha)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From comment #29 in bug #108973

It would be nice if closing a window saved the contents (all tabs) as a bookmark
group to session history, so that if the window was closed by mistake (for
example, the user didn't realize that it contained other open tabs until after
he/she has closed it) it could be resurrected (to a certain extent) by clicking
on the bookmark group in the History sidebar.

Updated

17 years ago
Summary: save contents of window as group to session history when closing → save contents of window as group to session history when closing

Comment 1

17 years ago
this is atleast a duplicate of bug 127637 ('Setting (pref) needed to
save/remember tabs/windows state for next (or default) start of mozilla')

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 127637 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
This is *not* a dup of bug #127637. That is for when the browser exits. This is
for closing a single window. It should be possible to use this feature to
recover a closed window from the current browsing session.

Comment 4

17 years ago
comment #3 does not reflect the description of this bug, the description speaks
of a "window" (a window contains multiple tabs, but the tabs are not 'windows' -
atleast in the way people generally speak of user interfaces - the reporter
appears to recognise this in the bug description but not in comment #3)

if the description is changed to reflect comment #3, I suggest this is
functionality is in part covered by the browser History and should be marked WONTFIX

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.