If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

impossible to select single word when alignment is justify

RESOLVED DUPLICATE of bug 58704

Status

()

Core
Selection
RESOLVED DUPLICATE of bug 58704
16 years ago
16 years ago

People

(Reporter: Rudmer van Dijk, Assigned: mjudge)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020414
BuildID:    2002041409-1.0.0

it is impossible to select a single word on this page (and others on this site)
however the whole line is selected when the cursor is moved up or down (it does
not matter where the cursor was, left, middle or at the right). After the whole
line is selected and the mouse is moved to the left or the right it is sometimes
(<10%) possible to select a part of the line and when that occored it is
possible to select a single word (but only on that line...)

it is possible to select a single word on this page when it is on the first line
(in a section <P align=justify>), the abillity to select a part of a line is
also only possible on the first (top) line (in a section <P align=justify>)...

the page does not have a doctype set, so the html-page is wrong, but as mozilla
displays the page, selections should behave correctly.

Reproducible: Always
Steps to Reproduce:
1. goto http://dunkels.com/adam/tfe/ (or probably any site which does not have a
doctype set)
2. try to select a single word that is not on the first line


Actual Results:  could not select a single word

Expected Results:  selected a single word

The following html demonstrates the problem:

<html><body>
<p align=justify>This is a test line to demonstrate a problem in
mozilla-2002041409-1.0.0: it should not be possible to select a SINGLE word in
the second line of this paragraph (which has its alignment set to justify)
however it should be possible to select a single word in the first (top) line of
this paragraph). If the alignment is changed to 'left', 'center' or 'right' then
the problem should not occur. Happy testing :)</p>
</body></html>

Comment 1

16 years ago
WFM 2002041408/Win2K

Comment 2

16 years ago
wfm build 2002041408 win98

Is it a Linux only bug?
Your given URL returns 403 Forbidden, so I've tried with the example you provide.

I was able to select a single word, or whatever sequence of characters, by
double clicking on a word, clicking and dragging the mouse, or clicking on a
character and then pressing SHIFT+any cursor key. Then to make sure everything
was working fine, I've pasted the text on a text editor and it worked properly.

Comment 3

16 years ago
I'm seeing the bug here on Linux on 2002041218. Double clicking on words in the
first line selects the word, double clicking on any word in the second or third
line, selects the first word on the line.
->Selection
Assignee: attinasi → mjudge
Component: Layout → Selection
QA Contact: petersen → tpreston
Duplicate of "cannot select anything smaller than lines in justified text"

*** This bug has been marked as a duplicate of 58704 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.