Status

()

Firefox for iOS
General
P1
normal
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: csuciu, Assigned: jhugman)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios8.0+, fxios-v8.0 affected)

Details

(Whiteboard: [MobileCore][AutoPush])

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
master/iPhone 6 Plus (10.3.2)

1. Background the app
2. Receive a tab on iOS
     => Fennec's badge counter shows "1"
3. Don't tap on the notification. Do not open Fennec.
4. Receive a second tab on iOS
    

Expected: Fennec's badge counter should increment every time a tab is received if the previous ones were not open. In this case it should show "2".

Result: Fennec's badge counter shows "1"
Assignee: nobody → jhugman
Status: NEW → ASSIGNED
tracking-fxios: ? → 8.0+
Priority: -- → P1
Summary: Fennec's badge counter does not increment when multiple tabs are received → Disable badge counter
Duplicate of this bug: 1375994
(Assignee)

Comment 2

8 months ago
Created attachment 8882267 [details] [review]
Link to Github pull-request: https://github.com/mozilla-mobile/firefox-ios/pull/2869
Attachment #8882267 - Flags: review?(jdarcangelo)
Attachment #8882267 - Flags: review?(jdarcangelo) → review+
(Assignee)

Comment 3

8 months ago
Merged into master.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
Whiteboard: [AutoPush] → [MobileCore][Autopush][needsuplift]
Uplifted to v8.x
Whiteboard: [MobileCore][Autopush][needsuplift] → [MobileCore][AutoPush]
You need to log in before you can comment on or make changes to this bug.