XUL tooltips and context menus apperar on wrong monitor when using multiple GPUs

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
a year ago
9 months ago

People

(Reporter: miha.frangez, Unassigned)

Tracking

41 Branch
Points:
---

Firefox Tracking Flags

(firefox57 fix-optional, firefox58 wontfix, firefox59 fix-optional)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170520072017

Steps to reproduce:

Trigger any floating item (context menu, tooltip, dropdown...) to appear on a monitor on the secondary GPU.
Example: https://youtu.be/uovVrhPQrv0 (left is Intel IGPU, right is NVIDIA dedicated GPU)

This happens in all current Firefox versions (including 54a2) and all other XUL applications (the one in the video uses xulrunner 41.0.2).

Env: GNU/Linux, X.Org 1.19.3, KWin, Plasma shell


Actual results:

The context menu (or whatever else) appears on edge of the closest monitor on the primary GPU (in the example, that is the leftmost monitor on the NVIDIA GPU)


Expected results:

The context menu (or whatever else) should have appeared at the cursor's position

Updated

a year ago
status-firefox57: --- → fix-optional
Priority: -- → P3

Updated

11 months ago
status-firefox58: --- → wontfix
status-firefox59: --- → fix-optional
(Reporter)

Comment 1

9 months ago
This bug no longer occurs. I don't know if it was fixed by a Firefox update or something else like X.Org, but it works properly now.
Please set it as fixed, I can't.
WORKSFORME instead of FIXED because we don't know what commit fixed this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.