Closed Bug 1375070 Opened 2 years ago Closed 2 years ago

5.08 - 6.21% damp (linux64, windows7-32) regression on push 72a0af4b7041879f651f2222838e41acc5ff60b5 (Tue Jun 20 2017)

Categories

(DevTools :: Inspector, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: igoldan, Unassigned)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=72a0af4b7041879f651f2222838e41acc5ff60b5

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  6%  damp summary windows7-32 opt e10s     260.97 -> 277.17
  5%  damp summary linux64 opt e10s         232.76 -> 244.59


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=7444

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
:gl Could you take a look over this developer tools perf regression and estimate a fix time for it?
Flags: needinfo?(gl)
this seems to be fixed:
== Change summary for alert #7480 (as of June 22 2017 01:14 UTC) ==

Improvements:

  6%  damp summary windows7-32 opt e10s     277.41 -> 260.53
  4%  damp summary linux64 opt e10s         244.25 -> 234.75

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=7480

this looks to be a merge in, but the merge from inbound has no data which shows the regression- is it possible this was fixed on mozilla-central somehow?
I would like to close this bug, please comment if you would like this to remain open
Flags: needinfo?(gl)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.