Browser seems to forget credentials

RESOLVED WORKSFORME

Status

SeaMonkey
Passwords & Permissions
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Laurent Duperval, Assigned: Stephen P. Morse)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I have a login/password on netbeans.org. When I get to the site, I can login
using the available form. This login allows me to use the bugzilla for netbeans,
much like here. However, I've noticed recently that when I try to create a new
issue for netbeans, Mozilla seems to @forget" my credentials. I login but when I
want to file a bug report, it asks me to login again. No matter what I do, I
can't get passed the login screen to file a report. 

I have also noticed this with another private site. On that site, whenever I try
to access a page, I am sent back to the login page where I reenter my ID
password and then I get access to the page I want. And I have to repeat the
process in order to access most pages on the site. I don't see that behaviour
with Netscape 6.2 and I also didn't use to see this with earlier versions of the
Lizard. I'm not sure exactly when this started happening.
-> password manager for triage
Assignee: Matti → morse
Component: Browser-General → Password Manager
QA Contact: imajes-qa → tpreston
(Assignee)

Comment 2

16 years ago
Can you give a step-by-step sequence for reproducing this problem starting with 
a fresh profile.
(Reporter)

Comment 3

16 years ago
Hmmm, a fresh profile will require a bit of time. How do I create a fresh profile?
(Assignee)

Comment 4

16 years ago
mozilla -profilemanager

Comment 5

16 years ago
IMHO, it's not a password manager problem, since the reporter manually fills in 
his credentials... the password manager does not play a role in this.

Laurent Duperval, check in Preferences that Mozilla can accept cookies.  It's 
also a possibility that the site itself doesn't allow you to save your login 
session-to-session... does the login form have a checkbox like "autologin" 
or "save password"?

If not, I suggest that you go into Preferences, and configure Mozilla to prompt 
you for every cookie that a site wants to save.  When you log in to Netbeans 
(or any other site), look at the cookie's details and note its expiration date.

Check to see whether it's something like "End of session" or within the next 
few hours...  I've never seen Mozilla's cookie prompt, so I can't be more 
specific.
(Reporter)

Comment 6

16 years ago
Ok, I think I found it. In my preferences, the cookies were only  being allowed 
if they originated from the same server. By changing that to all cookies, the
problem went away.

Is it possible to have a warning when a cookie is coming from a different server?
Also, I notice that the prompt gives less information than it used to (either in
Netscape or earlier versions of Mozilla you got the name of the cookie and its
expiration date). Can an option be added to specify more or less verbosity?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

16 years ago
> Also, I notice that the prompt gives less information than it used to
> (either in Netscape or earlier versions of Mozilla you got the name of the
> cookie and its expiration date).

Not true.  Mozilla has never given this information in the cookie warning box.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.