getting service at shutdown (cookie stuff)

RESOLVED DUPLICATE of bug 158216

Status

()

Core
Networking: Cookies
--
minor
RESOLVED DUPLICATE of bug 158216
16 years ago
15 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
FreeBSD4.4 CVS Build from last weekend + patches (xpcom) to get TestCookie to stop crashing + patch to prevent XPCOM Reinitialization at shutdown.

Getting service on shutdown. Denied.
         CID: {f00152d0-b40b-11d3-8c9c-000064657374}
         IID: {61c1b3c0-b1bf-11d3-93b6-00104ba0fd40}
###!!! ASSERTION: stop for CID: '0', file /home/timeless/mozilla/xpcom/components/nsComponentManager.cpp, line 1878
###!!! Break: at file /home/timeless/mozilla/xpcom/components/nsComponentManager.cpp, line 1878
Suspending process; attach with the debugger.

Program received signal SIGSTOP, Stopped (signal).
0x283147d0 in kill () from /usr/lib/libc_r.so.4
(gdb) where
#0  0x283147d0 in kill () from /usr/lib/libc_r.so.4
#1  0x281a4c4f in nsDebug::Break (aFile=0x281f40c0 "/home/timeless/mozilla/xpcom/components/nsComponentManager.cpp", aLine=1878)
    at /home/timeless/mozilla/xpcom/glue/nsDebug.cpp:322
#2  0x281a4b31 in nsDebug::Assertion (aStr=0x281f4b0a "stop for CID", aExpr=0x281f4b08 "0",
    aFile=0x281f40c0 "/home/timeless/mozilla/xpcom/components/nsComponentManager.cpp", aLine=1878) at /home/timeless/mozilla/xpcom/glue/nsDebug.cpp:291
#3  0x2814ae25 in nsComponentManagerImpl::GetService (this=0x8074000, aClass=@0x281e8014, aIID=@0x281d63e8, result=0xbfbfebe4)
    at /home/timeless/mozilla/xpcom/components/nsComponentManager.cpp:1878
#4  0x281a753e in nsGetServiceByCID::operator() (this=0xbfbfec70, aIID=@0x281d63e8, aInstancePtr=0xbfbfebe4)
    at /home/timeless/mozilla/xpcom/glue/nsComponentManagerUtils.cpp:101
#5  0x0804bc93 in nsCOMPtr<nsIProperties>::assign_from_helper (this=0xbfbfec80, helper=@0xbfbfec70, aIID=@0x281d63e8) at ../../../dist/include/xpcom/nsCOMPtr.h:922
#6  0x281b0d33 in nsCOMPtr<nsIProperties>::nsCOMPtr (this=0xbfbfec80, helper=@0xbfbfec70) at ../../../../dist/include/xpcom/nsCOMPtr.h:553
#7  0x281b5f49 in NS_GetSpecialDirectory (specialDirName=0x283d1956 "ProfD", result=0xbfbfed10) at ../../dist/include/xpcom/nsDirectoryServiceUtils.h:38
#8  0x283c0010 in CKutil_ProfileDirectory (dirSpec=@0xbfbfed80) at /home/timeless/mozilla/extensions/cookie/nsUtils.cpp:126
#9  0x283bbcc5 in COOKIE_Write () at /home/timeless/mozilla/extensions/cookie/nsCookies.cpp:1590
#10 0x283b4d7f in nsCookieService::~nsCookieService (this=0x812fac0, __in_chrg=3) at /home/timeless/mozilla/extensions/cookie/nsCookieService.cpp:76
#11 0x283b4af7 in nsCookieService::Release (this=0x812fac0) at /home/timeless/mozilla/extensions/cookie/nsCookieService.cpp:64
#12 0x281016a6 in nsSupportsArray::Clear (this=0x80ae940) at /home/timeless/mozilla/xpcom/ds/nsSupportsArray.cpp:600
#13 0x28100a56 in nsSupportsArray::DeleteArray (this=0x80ae940) at /home/timeless/mozilla/xpcom/ds/nsSupportsArray.cpp:303
#14 0x28100212 in nsSupportsArray::~nsSupportsArray (this=0x80ae940, __in_chrg=3) at /home/timeless/mozilla/xpcom/ds/nsSupportsArray.cpp:146
#15 0x281005ab in nsSupportsArray::Release (this=0x80ae940) at /home/timeless/mozilla/xpcom/ds/nsSupportsArray.cpp:238
#16 0x281ac8f2 in nsCOMPtr<nsISupportsArray>::~nsCOMPtr (this=0x80c5734, __in_chrg=2) at ../../../../dist/include/xpcom/nsCOMPtr.h:490
#17 0x280fa6f8 in nsObserverList::~nsObserverList (this=0x80c5730, __in_chrg=3) at /home/timeless/mozilla/xpcom/ds/nsObserverList.cpp:57
#18 0x280fb6f1 in ReleaseObserverList (aKey=0x80b2ba0, aData=0x80c5730, closure=0x0) at /home/timeless/mozilla/xpcom/ds/nsObserverService.cpp:109
#19 0x280f783f in _hashEnumerateRemove (he=0x80c5770, i=4, arg=0xbfbff040) at /home/timeless/mozilla/xpcom/ds/nsHashtable.cpp:371
#20 0x28226074 in PL_HashTableEnumerateEntries (ht=0x812eac4, f=0x280f7800 <_hashEnumerateRemove(PLHashEntry *, int, void *)>, arg=0xbfbff040)
    at /home/timeless/mozilla/nsprpub/lib/ds/plhash.c:429
#21 0x280f78ef in nsHashtable::Reset (this=0x812eac0, destroyFunc=0x280fb6c4 <ReleaseObserverList(nsHashKey *, void *, void *)>, aClosure=0x0)
    at /home/timeless/mozilla/xpcom/ds/nsHashtable.cpp:390
#22 0x280f93ac in nsObjectHashtable::Reset (this=0x812eac0) at /home/timeless/mozilla/xpcom/ds/nsHashtable.cpp:918
#23 0x280f9263 in nsObjectHashtable::~nsObjectHashtable (this=0x812eac0, __in_chrg=3) at /home/timeless/mozilla/xpcom/ds/nsHashtable.cpp:884
#24 0x280fb590 in nsObserverService::~nsObserverService (this=0x812dd30, __in_chrg=3) at /home/timeless/mozilla/xpcom/ds/nsObserverService.cpp:84
#25 0x280fb3c8 in nsObserverService::Release (this=0x812dd30) at /home/timeless/mozilla/xpcom/ds/nsObserverService.cpp:72
#26 0x281acdec in nsCOMPtr_base::assign_assuming_AddRef (this=0x80712bc, newPtr=0x0) at /home/timeless/mozilla/xpcom/glue/nsCOMPtr.h:435
#27 0x281a4979 in nsCOMPtr_base::assign_with_AddRef (this=0x80712bc, rawPtr=0x0) at /home/timeless/mozilla/xpcom/glue/nsCOMPtr.cpp:73
#28 0x281ab8f5 in nsCOMPtr<nsISupports>::operator= (this=0x80712bc, rhs=0x0) at ../../../dist/include/xpcom/nsCOMPtr.h:795
#29 0x2814ac62 in FreeServiceContractIDEntryEnumerate (aTable=0x8074048, aHdr=0x8127918, aNumber=590, aData=0x0)
    at /home/timeless/mozilla/xpcom/components/nsComponentManager.cpp:1837
#30 0x280eec0e in PL_DHashTableEnumerate (table=0x8074048, etor=0x2814ac10 <FreeServiceContractIDEntryEnumerate(PLDHashTable *, PLDHashEntryHdr *, unsigned int, void *)>,
    arg=0x0) at /home/timeless/mozilla/xpcom/ds/pldhash.c:600
#31 0x2814acf9 in nsComponentManagerImpl::FreeServices (this=0x8074000) at /home/timeless/mozilla/xpcom/components/nsComponentManager.cpp:1850
#32 0x280edaec in NS_ShutdownXPCOM (servMgr=0x0) at /home/timeless/mozilla/xpcom/build/nsXPComInit.cpp:549
#33 0x0804b41c in main (argc=1, argv=0xbfbff43c) at /home/timeless/mozilla/extensions/cookie/tests/TestCookie.cpp:138

Updated

16 years ago
Target Milestone: --- → mozilla1.2beta
(Assignee)

Comment 1

16 years ago
I think you want a shutdown listener.

Comment 2

16 years ago
Is this still a problem?  Does it happen every time you close the browser.

tever, can you reproduce this?  I'm not able to.

Updated

16 years ago
Target Milestone: mozilla1.2beta → ---

Comment 3

16 years ago
Changing summary to something meaningful.  Original summary was:

   nsCookieService::~nsCookieService => COOKIE_Write => CKutil_ProfileDirectory
   Getting service on shutdown.
   Denied. CID: {f00152d0-b40b-11d3-8c9c-000064657374}

New summary (based on my reading of the description field) is

   get TestCookie to stop crashing
Summary: nsCookieService::~nsCookieService => COOKIE_Write => CKutil_ProfileDirectory Getting service on shutdown. Denied. CID: {f00152d0-b40b-11d3-8c9c-000064657374} → get TestCookie to stop crashing
Target Milestone: --- → Future
.
Assignee: morse → timeless
Summary: get TestCookie to stop crashing → getting service at shutdown (cookie stuff)
(Assignee)

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 158216 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.