Mousewheel scrolling doesn't work in Calendar window

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: ajbu, Assigned: ajbu)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
Mozilla build 2002041306, Calendar 04/03/02
Steps to reproduce:
- Start Mozilla
- Start Calendar
- Open a week or day view so there are visible vertical scrollbars
- Move your mouse inside the window with scrollbars and roll the mousewheel

Expected result: Window scrolls
Actual result: nothing happens

Comment 1

16 years ago
Clicking the calendar both on and off events and using ctrl+click has no effect.
 April 24 build.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Sending this bug to nobody@mozilla.org.  If you can do this, please assign it to
yourself and go for it!
Assignee: mikep → nobody
Keywords: helpwanted
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

16 years ago
box supports mousewheel scrolling, but it doesn't work in Calendar because the 
view never gets focus.
After setting focus to the Calendar views, scrolling works as expected.
Not sure what is the cleanest ways to do this, onclick in js, xul or css.

Can be done by adding the property:
   -moz-user-focus      : normal
to calendar.css for .day-view-event-text-class, .day-view-event-text-
class, .week-view-hour-box-class, .week-view-event-class

(sorry, no cvs/diff here..)
Assignee: nobody → ajbu
Status: ASSIGNED → NEW
(Assignee)

Comment 4

16 years ago
Created attachment 89680 [details] [diff] [review]
Patch for classic skin calendar.css

allows focus on week/day-view events and hours

Comment 5

16 years ago
*** Bug 155295 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Checked into CVS, the only thing now is that you have to click on the day view
and week view in order to focus it, I can't figure out how to focus the boxes
without having to click on them. 
document.getElementById( "boxtofocus" ).focus() doesn't work.
Status: NEW → ASSIGNED

Comment 7

16 years ago
Maybe "focus" isn't the problem. Most other applications will allow mousewheel
scrolling just by *hovering* over the scrollable area (no click needed, no
visible "focussing" occurs). I don't think that involves "focus" (but maybe I
understand the term "focus" wrong). There is a longstanding :( bug somewhere
(#?) about the mousewheel not always scrolling properly.
(Assignee)

Comment 8

16 years ago
Following code seems to work on Windows XP, switching views with the toolbar 
buttons make the view scroll with the mousewheel without clicking. Only thing 
missing is focus on initial view.


/** PUBLIC
*
*   Switch to the day view if it isn't already the current view
*/

CalendarWindow.prototype.switchToDayView = function( )
{
   document.getElementById("day-tree-item-0").focus();

   this.switchToView( this.dayView )
}


/** PUBLIC
*
*   Switch to the week view if it isn't already the current view
*/

CalendarWindow.prototype.switchToWeekView = function( )
{
   document.getElementById("week-tree-hour-0").focus();

   this.switchToView( this.weekView )
}

Comment 9

16 years ago
Checked into CVS, the only thing left is that if you start the calendar in
something other than month view, it doesn't work.
(Assignee)

Comment 10

16 years ago
It work for me when setting the focus in the CalendarWindow constructor:
   switch( SelectedIndex )
   {
      case "1":
         this.currentView = this.weekView;
         document.getElementById("week-tree-hour-0").focus();

         break;
      case "2":
         this.currentView = this.dayView;
         document.getElementById("day-tree-item-0").focus();

         break;

Comment 11

16 years ago
Fixed in CVS, new build will come next week sometime.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 12

16 years ago
Default QA Contact for Calendar has changed.  If you wish to remain the QA
contact for this bug, feel free to change it back.
QA Contact: colint → brantgurganus2001
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird

Updated

9 years ago
Keywords: helpwanted
You need to log in before you can comment on or make changes to this bug.