Closed Bug 1375166 Opened 5 years ago Closed 5 years ago

[mozlint] Can't run single file with |mach eslint|

Categories

(Firefox Build System :: Lint and Formatting, defect)

defect
Not set
normal

Tracking

(firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: ahal, Assigned: ahal)

References

Details

Attachments

(1 file)

This is a regression from bug 1288432. Running ./mach eslint <path/to/file.js> does not lint the file. This happens because mozlint is expecting the 'extensions' [1] to start with a period.

This is silly, mozlint should strip any leading periods if found.

[1] https://dxr.mozilla.org/mozilla-central/rev/e1e4a481b7e88dce163b9cccc2fb72032023befa/tools/lint/eslint.yml#8
Comment on attachment 8880059 [details]
Bug 1375166 - [mozlint] Don't require leading '.' in extensions,

https://reviewboard.mozilla.org/r/151388/#review156780

Looks great, thank you.
Attachment #8880059 - Flags: review?(standard8) → review+
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2b190948b81b
[mozlint] Don't require leading '.' in extensions, r=standard8
https://hg.mozilla.org/mozilla-central/rev/2b190948b81b
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Product: Testing → Firefox Build System
You need to log in before you can comment on or make changes to this bug.