Closed Bug 1375198 Opened 2 years ago Closed 2 years ago

./mach bootstrap fails on FreeBSD

Categories

(Firefox Build System :: General, defect)

Unspecified
FreeBSD
defect
Not set

Tracking

(firefox-esr52 fixed, firefox54 wontfix, firefox55 fixed, firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- fixed
firefox54 --- wontfix
firefox55 --- fixed
firefox56 --- fixed

People

(Reporter: jbeich, Assigned: jbeich)

Details

Attachments

(1 file)

libGL package was renamed to mesa-libs. This affects only /latest package set until 2017Q3 is branched. gtk3 (via libepoxy) or gtk2 (via cairo) already depend on mesa-libs indirectly, so one can drop the explicit dependency to avoid the churn on updates.

https://svnweb.freebsd.org/changeset/ports/440699

$ ./mach bootstrap
[...]
Executing as root: su root -c "pkg install dbus-glib gconf2 gtk2 gtk3 libGL pulseaudio v4l_compat yasm"
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
pkg: No packages available to install matching 'libGL' have been found in the repositories
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

CalledProcessError: Command '[u'su', u'root', u'-c', u'pkg install dbus-glib gconf2 gtk2 gtk3 libGL pulseaudio v4l_compat yasm']' returned non-zero exit status 70

  File "/mozilla-central/python/mozboot/mozboot/mach_commands.py", line 26, in bootstrap
    bootstrapper.bootstrap()
  File "/mozilla-central/python/mozboot/mozboot/bootstrap.py", line 255, in bootstrap
    getattr(self.instance, 'install_%s_packages' % application)()
  File "/mozilla-central/python/mozboot/mozboot/freebsd.py", line 64, in install_browser_packages
    self.ensure_browser_packages()
  File "/mozilla-central/python/mozboot/mozboot/freebsd.py", line 71, in ensure_browser_packages
    self.pkg_install(*self.browser_packages)
  File "/mozilla-central/python/mozboot/mozboot/freebsd.py", line 58, in pkg_install
    self.run_as_root(command)
  File "/mozilla-central/python/mozboot/mozboot/base.py", line 315, in run_as_root
    subprocess.check_call(command, stdin=sys.stdin)
  File "/usr/local/lib/python2.7/subprocess.py", line 186, in check_call
    raise CalledProcessError(retcode, cmd)
Comment on attachment 8880086 [details]
Bug 1375198 - FreeBSD bootstrap: drop explicit dependency on libGL.

https://reviewboard.mozilla.org/r/151436/#review156418

::: commit-message-92eb9:2
(Diff revision 1)
> +Bug 1375198 - Drop explicit dependency on libGL package. r?rillian
> +

Please add the first paragraph from the bug description to the commit message, about how the package name has changed, but gtk has a transitive dependency so we can remove the old name without affecting the build. So people don't have to read the bug to find out what the motivation was.
Attachment #8880086 - Flags: review?(giles) → review+
Keywords: checkin-needed
Assignee: nobody → jbeich
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ce2cf9dcf077
FreeBSD bootstrap: drop explicit dependency on libGL. r=rillian
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ce2cf9dcf077
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Comment on attachment 8880086 [details]
Bug 1375198 - FreeBSD bootstrap: drop explicit dependency on libGL.

Approval Request Comment
[ESR consideration]: Easier dogfooding *without* downstream patches
[Feature/Bug causing the regression]: Regression caused by a downstream change since 2017-05-12
[User impact if declined]: Broken ./mach bootstrap on FreeBSD and DragonFly
[Is this code covered by automated tests?]: NPOTB
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Can only break ./mach bootstrap due to typos causing syntax errors when maybe unused modules are imported (but not yet run).
[String changes made/needed]: None
Attachment #8880086 - Flags: approval-mozilla-esr52?
Attachment #8880086 - Flags: approval-mozilla-beta?
Comment on attachment 8880086 [details]
Bug 1375198 - FreeBSD bootstrap: drop explicit dependency on libGL.

npotb, seems ok for beta
Attachment #8880086 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 8880086 [details]
Bug 1375198 - FreeBSD bootstrap: drop explicit dependency on libGL.

Looks low risk. Let's uiplift this to ESR52.3
Attachment #8880086 - Flags: approval-mozilla-esr52? → approval-mozilla-esr52+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.