If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Segfault on back button after searching this directory

VERIFIED DUPLICATE of bug 123914

Status

SeaMonkey
General
--
critical
VERIFIED DUPLICATE of bug 123914
16 years ago
13 years ago

People

(Reporter: Mike Roberto, Assigned: Matti)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/0
BuildID:    0.9.9

Go to http://www.osu.edu/cgi-bin/Inquiry and enter in mike.roberto to bring up
my information.

Try clicking the back button now.  It segfaults every time for me.  Let me know
if you need more information.

Reproducible: Always
Steps to Reproduce:
1.Go to the above URL
2.Enter in anybody's info
3.hit the back button

Actual Results:  Segfault

Expected Results:  Should go back to the search page

Comment 1

16 years ago
Works fine for me. I'm using Build ID 2002040814 on Linux.

Comment 2

16 years ago
Works fine for me. Build 2002041203. W2k.

Comment 3

16 years ago
WFM 2002041408/Win2K

Reporter, could you install the latest nightly build and try it again?
http://ftp.mozilla.org/pub/mozilla/nightly/latest/

BTW If you are crashing in Mozilla the best thing you can do to help the
developers fix your bug is to attach a stacktrace. If you're not building
yourself you are not out of luck. Mozilla releases nightly and milestone builds
with Full Circle's Talkback (you can get latest build on:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/) Talkback should catch most
crashes and offer to send in a crash report. Developers can retrieve that crash
report and attach it to your bug report if you provide either the Incident ID
(you can get it by running the talkback program from /components/talkback/).
Thanks for your help in testing Mozilla and reporting bugs.
Severity: minor → critical
Keywords: crash

Comment 4

16 years ago
WFM, Linux. CVS build from noon Apr. 14th.

Comment 5

16 years ago
It does crash indeed in 0.9.9 with the same stack and symptoms as bug 123914 
(which has been fixed last month)

#0  0x41c012a3 in nsIsIndexFrame::GetInputFrame(nsIPresContext*,
nsIFormControlFrame**) (this=0x8c92eb8, 
    aPresContext=0x8a86a18, oFrame=0xbfffce90) at nsIsIndexFrame.cpp:182
#1  0x41c013a3 in nsIsIndexFrame::SetInputValue(nsIPresContext*, nsString)
(this=0x8c92eb8, aPresContext=0x8a86a18, 
    aString=0xbfffceb0) at nsIsIndexFrame.cpp:205
#2  0x41c033dd in nsIsIndexFrame::RestoreState(nsIPresContext*, nsIPresState*)
(this=0x8c92eb8, 
    aPresContext=0x8a86a18, aState=0x8c0e450) at nsIsIndexFrame.cpp:621
#3  0x41b585fa in FrameManager::RestoreFrameStateFor(nsIPresContext*, nsIFrame*,
nsILayoutHistoryState*, nsIStatefulFrame::SpecialStateID) (this=0x8be5858,
aPresContext=0x8a86a18, aFrame=0x8c92eb8, aState=0x8ae3e70, aID=eNoID)
    at nsFrameManager.cpp:2346
...

*** This bug has been marked as a duplicate of 123914 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.