Closed Bug 1375259 Opened 2 years ago Closed 2 years ago

Intermittent test_visibility.py TestVisibility.testShouldAllowTheUserToTellIfAnElementIsDisplayedOrNot | TypeError: close() takes at most 2 arguments (3 given)

Categories

(Testing :: Marionette, defect)

Version 3
All
Android
defect
Not set

Tracking

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 fixed, firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed
firefox56 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

[task 2017-06-21T14:19:46.575220Z] 14:19:46  WARNING -  TEST-UNEXPECTED-ERROR | test_visibility.py TestVisibility.testShouldAllowTheUserToTellIfAnElementIsDisplayedOrNot | TypeError: close() takes at most 2 arguments (3 given)
[task 2017-06-21T14:19:46.577002Z] 14:19:46     INFO -  Traceback (most recent call last):
[task 2017-06-21T14:19:46.577100Z] 14:19:46     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_harness/marionette_test/testcases.py", line 138, in run
[task 2017-06-21T14:19:46.577146Z] 14:19:46     INFO -      self.setUp()
[task 2017-06-21T14:19:46.577229Z] 14:19:46     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_harness/marionette_test/testcases.py", line 322, in setUp
[task 2017-06-21T14:19:46.577273Z] 14:19:46     INFO -      sandbox="simpletest")
[task 2017-06-21T14:19:46.577353Z] 14:19:46     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 1751, in execute_script
[task 2017-06-21T14:19:46.577409Z] 14:19:46     INFO -      rv = self._send_message("executeScript", body, key="value")
[task 2017-06-21T14:19:46.577642Z] 14:19:46     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/decorators.py", line 28, in _
[task 2017-06-21T14:19:46.577863Z] 14:19:46     INFO -      m._handle_socket_failure()
[task 2017-06-21T14:19:46.578625Z] 14:19:46     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 815, in _handle_socket_failure
[task 2017-06-21T14:19:46.578672Z] 14:19:46     INFO -      self.cleanup()
[task 2017-06-21T14:19:46.578870Z] 14:19:46     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 635, in cleanup
[task 2017-06-21T14:19:46.579107Z] 14:19:46     INFO -      self.instance.close(clean=True)
[task 2017-06-21T14:19:46.579413Z] 14:19:46     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/geckoinstance.py", line 404, in close
[task 2017-06-21T14:19:46.579645Z] 14:19:46     INFO -      super(FennecInstance, self).close(restart, clean)

Uh, looks like a fallout from bug 1373635. Not sure why this is happening so rarely and did fail only once until now.
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
OS: Unspecified → Android
Hardware: Unspecified → All
Blocks: 1373635
Keywords: regression
Attachment #8880789 - Flags: review?(ato)
Comment on attachment 8880789 [details]
Bug 1375259 - Fix FennecInstance.close() for removal of restart keyword.

https://reviewboard.mozilla.org/r/152160/#review157258
Attachment #8880789 - Flags: review?(ato) → review+
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6c30688a5e91
Fix FennecInstance.close() for removal of restart keyword. r=ato
https://hg.mozilla.org/mozilla-central/rev/6c30688a5e91
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Test-only fix for a regression introduced in 55.0. Please uplift the patch.
Whiteboard: [checkin-needed-beta]
You need to log in before you can comment on or make changes to this bug.