Closed Bug 1375348 Opened 4 years ago Closed 4 years ago

Crash in IPCError-browser | PDocAccessibleParent::RecvRoleChangedEvent

Categories

(Core :: Disability Access APIs, defect)

56 Branch
Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 --- fixed

People

(Reporter: jtojnar, Assigned: eeejay)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-ff643ef1-c9eb-4af5-97da-d6d940170622.
=============================================================

Content process consistently crashes when visiting http://www.omgubuntu.co.uk/2017/06/nylas-mail-is-dead-jim, even on a fresh profile.
There are 46 crashes in nightly 56, they started with buildid 20170620030208.

:aklotz, could you investigate please ?
Component: General → Disability Access APIs
Flags: needinfo?(aklotz)
Product: Firefox → Core
Target Milestone: --- → mozilla55
Version: 55 Branch → 56 Branch
RecvRoleChangedEvent fails when aRole >= roles::LAST_ROLE.

This is kinda beyond my purview. Redirecting to davidb to assign.
Flags: needinfo?(aklotz) → needinfo?(dbolter)
eeejay is on it
Assignee: nobody → eitan
Flags: needinfo?(dbolter)
It seems the stack leads to the Role() method returns unexpeted value, which is unlikely to me. It's probably a good idea to move the assertion up in the callers chain to see who's giving a bad value.
Comment on attachment 8880556 [details] [diff] [review]
Include last role as a good role to recieve from child. r?davidb

Review of attachment 8880556 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Eitan Isaacson [:eeejay] from comment #5)
> Created attachment 8880556 [details] [diff] [review]
> Include last role as a good role to recieve from child. r?davidb

good catch, unhappy FOOTNOTE :) stealing r? from david
Attachment #8880556 - Flags: review?(dbolter) → review+
(In reply to alexander :surkov from comment #6)
> Comment on attachment 8880556 [details] [diff] [review]
> Include last role as a good role to recieve from child. r?davidb
> 
> Review of attachment 8880556 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> (In reply to Eitan Isaacson [:eeejay] from comment #5)
> > Created attachment 8880556 [details] [diff] [review]
> > Include last role as a good role to recieve from child. r?davidb
> 
> good catch, unhappy FOOTNOTE :) stealing r? from david

ARTICLE :)

Thanks!
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/783235a85c0f
Include last role as a good role to recieve from child. r=davidb
https://hg.mozilla.org/mozilla-central/rev/783235a85c0f
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1375137
Target Milestone: mozilla55 → mozilla56
You need to log in before you can comment on or make changes to this bug.