SystemGroup::EventTargetFor can segfault

RESOLVED DUPLICATE of bug 1384631

Status

()

P2
normal
RESOLVED DUPLICATE of bug 1384631
a year ago
a year ago

People

(Reporter: Nika, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Before SystemGroup::InitStatic, and after SystemGroup::Shutdown calling SystemGroup::EventTargetFor can segfault. This causes test failures for bug 1372433, as sometimes we receive messages on PContent during a time when SystemGroupImpl::sSingleton is null.

We should avoid making this code segfault if possible.

Updated

a year ago
OS: Unspecified → All
Priority: -- → P2
Hardware: Unspecified → All
(Reporter)

Comment 1

a year ago
I think this was fixed by bug 1384631
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384631
You need to log in before you can comment on or make changes to this bug.