Firefox Nightly from Play Store shows update notifications even though auto-updating is on

RESOLVED DUPLICATE of bug 1372623

Status

()

RESOLVED DUPLICATE of bug 1372623
2 years ago
2 years ago

People

(Reporter: liuche, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Created attachment 8880479 [details]
Screenshot: Update available for Nightly

Downloaded Firefox Nightly from Play Store, but it still shows "update" notifications in the Android system bar. We should remove these because they're duplicated and no other apps send notifications to update (and if they do, are considered annoying).

Other additional notifications include:
"Nightly is up to date: search or enter address"

"Find out what's new in this ver..: Speak now" with a progress bar: this string is too long, and clicking on this doesn't do anything, and I have no idea what the "speak now" is.

Unless these notifications do something that isn't being done by the system, I don't think we should show any of these notifications.
(Reporter)

Comment 1

2 years ago
Created attachment 8880481 [details]
Screenshot: Nightly is up to date
(Reporter)

Comment 2

2 years ago
Created attachment 8880482 [details]
Screenshot: Find out what's new in this ver.. [string is also too long]
(Reporter)

Updated

2 years ago
Attachment #8880482 - Attachment description: Screenshot: Find out what's new in this ver.. → Screenshot: Find out what's new in this ver.. [string is also too long]
The notifications being shown for a Play Store install is bug 1372623 I think. Since you've already uploaded all those screenshots, maybe this bug should be repurposed for rethinking the wording of those notifications?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Sorry, I originally wanted to mark this as a duplicate, then changed my mind and reloaded the page - it seems that if you then press "Edit bug", Bugzilla defaults to setting the bug status to "FIXED".
Status: REOPENED → NEW
(Reporter)

Comment 5

2 years ago
Comment on attachment 8880482 [details]
Screenshot: Find out what's new in this ver.. [string is also too long]

I'm removing this screenshot because I suspect it's a result of the strings mixup in bug 1375401.
Attachment #8880482 - Attachment is obsolete: true

Updated

2 years ago
Duplicate of this bug: 1390897
(Reporter)

Comment 7

2 years ago
Closing this bug to avoid further confusion because the strings mixup has been fixed, and this is really the Nightly update notification bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1372623
You need to log in before you can comment on or make changes to this bug.