Flickering line during scrolling at top of view port on Mac Nightly

RESOLVED WORKSFORME

Status

()

Core
Graphics
P1
normal
RESOLVED WORKSFORME
4 months ago
a month ago

People

(Reporter: haik, Unassigned)

Tracking

({regression})

56 Branch
Unspecified
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox56 fix-optional, firefox57 affected)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

4 months ago
When scrolling a webpage, on Nightly on OS X (latest Sierra), a thin flickering white line appears at the top of the view directly below the URL bar (or bookmarks bar if it is enabled.)

mozregression led me to

14:04.62 INFO: Narrowed inbound regression window from [958d2a5d, 0ff83c9d] (3 revisions) to [958d2a5d, 7f894f79] (2 revisions) (~1 steps left)
14:04.62 INFO: No more inbound revisions, bisection finished.
14:04.62 INFO: Last good revision: 958d2a5d10091401fd5e900e8e063d21940c137e
14:04.62 INFO: First bad revision: 7f894f791cdf170d788507d0eff30024ce699523
14:04.62 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=958d2a5d10091401fd5e900e8e063d21940c137e&tochange=7f894f791cdf170d788507d0eff30024ce699523
Bug 1359709 and bug 1361970 could be involved.  Matt, can you reproduce this?
status-firefox57: --- → affected
Flags: needinfo?(matt.woodrow)
Keywords: regression
Whiteboard: [gfx-noted]
Using 20170913100125 and Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0, I am not seeing any flickering directly below the URL bar. Using the latest Beta 9 seed.
I agree that those two bugs look suspicious here.

I can't reproduce it though. Maybe it has to do with resolution/DPI?
Flags: needinfo?(matt.woodrow)
What's your resolution/DPI?
status-firefox56: --- → fix-optional
Flags: needinfo?(haftandilian)
Priority: -- → P1
(Reporter)

Comment 5

a month ago
I can't reproduce this anymore. I tried on Nightly and Beta.

And I tried a reverse mozregression (--find-fix) but couldn't reproduce the original problem with

  $ mozregression --find-fix -b 7f894f791cdf170d788507d0eff30024ce699523 -g 2017-09-15

Hardware details: MacBook Pro (Retina, 15-inch, Mid 2015) -- 15.4-inch (2880 x 1800) -- Intel Iris Pro 1536 MB
Flags: needinfo?(haftandilian)
Thanks for the original bug report, and please reopen if it comes back!
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.