send-tab doesn't respect containers

RESOLVED DUPLICATE of bug 1288858

Status

()

RESOLVED DUPLICATE of bug 1288858
a year ago
a year ago

People

(Reporter: rillian, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I tried the new 'Send to Device' menu to transfer a tab between machines, which is a great feature. However, it doesn't respect tab containers. The tab I sent was in a container on the first machine, but came up unmarked on the second machine, dropping my login credentials and presumedly leaking tracking info.

Comment 1

a year ago
Kit/Jonathan, any idea why this doesn't work out of the box?
Component: General → Sync
Flags: needinfo?(kit)
Flags: needinfo?(jkt)
Unfortunately, it's expected that this doesn't work: we don't include the `userContextId` (or any other origin attributes) when we send a tab. We'd need to change the send tab command to support this. We'd also need to consider what happens if you try to send a container tab to iOS, which doesn't support them at all, or to a device where they're disabled.
Flags: needinfo?(kit)
Probably if a tab from a non-default container is sent to a browser which doesn't support containers, that browser should ignore the request. The sending client would ideally also either notify that it couldn't be sent while respecting privacy, or request confirmation before sending across container boundaries.
Another complication seems to be that containers are customizable on each client. IIUC, a simple integer defines the container ID (ie, it's not clear that a given integer value means the "same container" across devices), and I don't think the sending client can realistically know exactly how each other device is configured with containers.
Yeah containers names/icons/colours have no connection to sync still which would be an issue as :markh stated.
This might be easier to solve than some of the other sync bugs which require changes to the places store to account for userContextId.
Flags: needinfo?(jkt)
I knew we had something already...
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1288858
You need to log in before you can comment on or make changes to this bug.