Intermittent /service-workers/service-worker/xhr.https.html | application crashed [@ RefPtr<mozilla::dom::FetchBody<mozilla::dom::Response> >::operator->]

RESOLVED FIXED in Firefox 56

Status

()

--
critical
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: intermittent-bug-filer, Assigned: baku)

Tracking

({crash, intermittent-failure, regression})

unspecified
mozilla56
crash, intermittent-failure, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

Details

(crash signature)

Attachments

(1 attachment)

Duplicate of this bug: 1375768
3 failures in 892 pushes (0.003 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 2
* mozilla-central: 1

Platform breakdown:
* linux64: 2
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1375749&startday=2017-06-19&endday=2017-06-25&tree=all
(Assignee)

Updated

a year ago
Assignee: nobody → amarchesini
(Assignee)

Comment 3

a year ago
Created attachment 8881855 [details] [diff] [review]
crash.patch

I was able to reproduce it. Basically we release objects because the window goes away or the worker is released, but in the meantime we have a runnable in the queue for finishing the body consumption. When that runnable is executed, we crash because data has been already released.
Attachment #8881855 - Flags: review?(bkelly)
Attachment #8881855 - Flags: review?(bkelly) → review+

Comment 4

a year ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7c5cc1b39c89
Avoid FetchConsumer::ContinueConsumeBody() to be called more than once, r=bkelly
(Assignee)

Updated

a year ago
Duplicate of this bug: 1376282

Comment 6

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7c5cc1b39c89
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
32 failures in 718 pushes (0.045 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 9
* mozilla-inbound: 8
* mozilla-central: 6
* mozilla-beta: 5
* mozilla-esr52: 3
* try: 1

Platform breakdown:
* linux32: 11
* windows7-32-vm: 9
* linux64: 6
* linux64-stylo: 3
* windows8-64: 2
* linux32-nightly: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1375749&startday=2017-06-26&endday=2017-07-02&tree=all
Duplicate of this bug: 1378392
20 failures in 656 pushes (0.03 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 6
* autoland: 5
* try: 3
* mozilla-esr52: 3
* mozilla-central: 2
* mozilla-beta: 1

Platform breakdown:
* linux64-stylo: 11
* linux32: 4
* windows7-32-vm: 3
* windows8-64: 1
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1375749&startday=2017-07-03&endday=2017-07-09&tree=all
Blocks: 1371889
status-firefox54: --- → unaffected
status-firefox55: --- → affected
status-firefox-esr52: --- → affected
Do you want to request uplift to beta 55?
Flags: needinfo?(amarchesini)
Looks like this is taken care of in bug 1371889.
Flags: needinfo?(amarchesini)
Keywords: regression
9 failures in 720 pushes (0.013 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 4
* mozilla-inbound: 2
* autoland: 2
* mozilla-esr52: 1

Platform breakdown:
* linux64: 4
* linux64-stylo: 3
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1375749&startday=2017-07-10&endday=2017-07-16&tree=all
(Reporter)

Updated

a year ago
Blocks: 1381748
This won't be landing on 55.
status-firefox55: affected → unaffected
status-firefox-esr52: affected → unaffected
No longer blocks: 1381748
Depends on: 1381748
You need to log in before you can comment on or make changes to this bug.