If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Text selection may fail and highlight tables instead

VERIFIED WONTFIX

Status

()

Core
Selection
P3
normal
VERIFIED WONTFIX
18 years ago
18 years ago

People

(Reporter: cpratt, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build ID: 19990913xx
Platform: Windows NT, RH Linux 6

To reproduce:
- Launch apprunner
- Load http://www.yahoo.com
- Click to the right of the Hello Kitty (auction) link; hold the mouse button
down
- Move the mouse to the left. Note that text highlights correctly
- Keep moving the mouse to the left, but now move towards the top of the page as
well

Result: As soon as the mouse hits the table row above the current table cell,
the selection changes visually to show you the outlines of the table - and the
text selection goes away.

Expected result: Look at legacy Netscape browsers for expected behavior.
Basically, text selection works across multiple table cells/rows.

Comment 1

18 years ago
This is the intended implementation (DOM tree selection).

I don't personally like it, but it's been implemented this way in other
applications (e.g. Dreamweaver), although perhaps not necessarily ones that are
for non-expert users.

I've spoken with Mike, and he is not aware of any better implementations that can
be done using the existing architecture.
(Reporter)

Comment 2

18 years ago
This is intended? Surely you're kidding? This is a serious loss of functionality
vis-a-vis legacy Netscape browsers.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 3

18 years ago
nope not kidding. since we are doing DOM based selection now selecting from
inside one table to inside another table necessarily selects the whole table
since the html fragment of half a table doent make much sense. start a
discussion on the newsgroup netscape.public.mozilla.general or maybe
mozilla.layout if you think this is real bad.

Updated

18 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.