Closed Bug 1376025 Opened 4 years ago Closed 3 years ago

Mac Nightly opened with no windows or menus after updating, but restarting Nightly "fixed" the problem.

Categories

(Firefox :: Untriaged, defect)

Unspecified
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox56 --- affected

People

(Reporter: cpeterson, Unassigned)

References

Details

A couple people, myself included, reported problems with today's Mac Nightly update (2017-06-23).

My Mac Nightly showed an update available notification, so I allowed Nightly to restart. It started but no windows were session restored and the menus were not active. Quitting Nightly from the app's dock icon and restarting Nightly "fixed" the problem. I didn't need to force quit.

Mac updates were disabled for a day or so this week because Mac builds were moved from native Mac build machines to cross-compiled from Linux. Perhaps there was a hiccup when updating from a native-built Nightly to a cross-compiled Nightly?

I have not yet tried reproducing by reinstalling an older Nightly and re-updating to the cross-compiled build.

Nightly on Mac today has feels more beachball-y than usual today, but that might have been related to Firefox Sync.
Blocks: 1267425
Component: General → Untriaged
I haven't managed to test this issue due to the fact that the updates are disabled. However I wonder if this issue is related with bug 1375904.

@Kim, can you please take a look at this issue? Is there any chance that this issue is related to bug 1375904?
Flags: needinfo?(kmoir)
I could not reproduce this issue

The steps I took were 
download https://archive.mozilla.org/pub/firefox/nightly/2017/06/2017-06-21-10-23-01-mozilla-central/firefox-56.0a1.en-US.mac.dmg

which was the last build before the migration from this changeset
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&fromchange=c55e582aee5f4dd7c28cd9820156ecd0335e4e79&filter-job_type_symbol=N&selectedJob=108925857

install it locally

Kims-MacBook-Pro:Applications kmoir$ cat FirefoxNightly.app/Contents/Resources/defaults/pref/channel-prefs.js
/* This Source Code Form is subject to the terms of the Mozilla Public
 * License, v. 2.0. If a copy of the MPL was not distributed with this
 * file, You can obtain one at http://mozilla.org/MPL/2.0/. */

pref("app.update.channel", "nightlytest");

update the update channel to the nightlytest channel from the default of nightly since updates are disabled

(This is a special channel that you can explicitly set to test updates when regular updates are disabled.)

My nightly updated to the one from the 27th.  

I don't see the issues above.  That being said, this is a vanilla nightly without any extensions installed.

The upgraded nightly is not signed as per bug 1375904.  There are patches in staging to address 1375904 that we should be able to land soon.
Flags: needinfo?(kmoir)
User Agent  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID    20170712100330

I also wasn't able to reproduce the issue. I tried updating from the Nightly build from 2017-06-19 and 2017-06-21 and they both updated without an issue. I also had ~14 tabs opened and no add-ons.

Chris, have you encountered this issue since the report was made? If yes, could you post a list of all the add-ons you're using?
Flags: needinfo?(cpeterson)
I haven't seen it since that one time. I will close this bug as WORKSFORME.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(cpeterson)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.