smashcast.tv is resource intensive

RESOLVED INVALID

Status

()

RESOLVED INVALID
a year ago
10 months ago

People

(Reporter: megarig_2000, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170608105825

Steps to reproduce:

Watch a random stream, and try to type on the chat box.


Actual results:

Typing can be very laggy.


Expected results:

Fluid typing while watching stream.

Until then, disabling the video makes typing fluid but then what's the point of watching the stream if I can't see it?

Note: This site needs heavy optimizations as it affects all browsers(Chromium, Gecko, and Maxthon). It wouldn't affect IE 2 years ago, while it was called HitBox, so I'll have to test it. It's been this bad for the past 2 years.
Laptop with A6-6310, 4GB RAM, HDD, Windows 10 64-bit, Firefox 54 32-bit.

It performs good on my desktop but that's FX-6300, 8GB RAM, SSD, Windows 10 64-bit. Firefox 54 64-bit.
> This site needs heavy optimizations as it affects all browsers(Chromium, Gecko, and Maxthon)

Then please report the issue to the site in question.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Comment 2

a year ago
(In reply to Kohei Yoshino [:kohei] from comment #1)
> Then please report the issue to the site in question.

Yes, but Twitch and YouTube were the same until Firefox updates, so I was thinking if you guys also could do some part of it. Of course I will report it to them.
(Reporter)

Comment 3

a year ago
I'm still wondering if you guys could do something, like my reply above. Kohei, this is how you treat your users and want them to keep using Firefox? Let's just leave the problem be? Very disrespectful.
(Reporter)

Comment 4

10 months ago
I'll post a Performance while typing, hopefully it give you the idea. As nothing has changed, from their end. Assuming they think all is working great. You guys might be able to explain it better so I can send something more specific.

I think it is about the painting problem that was going on before, on Youtube years ago.
I'll also inform them of this but saying "Painting Problem" is too general.

I mean, it's smooth on my high-end desktop, but stuttery on my laptop. Same was with YouTube and Twitch, but now they are responsive since Firefox 56 on Twitch and 55 on YouTube, and even smoother with current 57 BETA, but Smashcast(Hitbox) hasn't changed.
(Reporter)

Comment 5

10 months ago
Created attachment 8917117 [details]
Possible Painting Problem
(Reporter)

Comment 6

10 months ago
Okay finally got a hold of someone that says he/she knows what the problem is. They also mentioned something about the not able to reproduce the problem but they also mentioned that they have an specific computer, which is powerful than mine.

So, I opened up Task Manager and while a stream is playing the CPU usage is 30% - 50%, no problems watching. When I start to type it jumps up to 60% - 80% and it stutters where the video part of the stream freezes until the letters finishing showing up, then all back to normal.
Okay, so it would be a problem that only they can fix, it would seem. But I had to report on both sides to make sure.
You need to log in before you can comment on or make changes to this bug.