single locale build te on stable 54.0 does not download files

RESOLVED INVALID

Status

()

Firefox for Android
Add-on Manager
RESOLVED INVALID
10 months ago
3 months ago

People

(Reporter: kr1shna, Unassigned)

Tracking

54 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec-, firefox54 affected, firefox55 affected, firefox56 affected, firefox57 wontfix)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Android 5.1; Mobile; rv:54.0) Gecko/54.0 Firefox/54.0
Build ID: 20170608225136

Steps to reproduce:

visit https://duckduckgo.com/?q=.pdf+file+download&t=h_&ia=web
download any pdf file


Actual results:

even after couple of minutes the download is not initialized. it does nothing.


Expected results:

the download file should start.
the issue is not repro on
55.0b3 locale build en-us
56.0a1 locale build te [ 20170615100256 ]
(Reporter)

Comment 1

10 months ago
Created attachment 8882074 [details]
download failure due to enabling cloud viewer add-on
(Reporter)

Comment 2

10 months ago
if i disable cloud viewer add-on [ https://addons.mozilla.org/en-US/android/addon/cloud-viewer/ ], i am able to download files without any issue.

herewith i am attaching log file created by logview add-on [ https://addons.mozilla.org/en-US/android/addon/logview/ ]

Comment 3

10 months ago
I was able to reproduce the issue on 54.0.1 te single locale build and with 55.0b3 multi build, but with a minor difference:
1. When you download a file, having cloud viewer enabled, a prompt asks if you wish to open it with Cloud viewer. If you choose yes, the file is opened in a new tab, but not downloaded (that's the scope of the add-on).
2. If you choose no, then another prompt asks to pick an app to download the file. Picking Firefox does not download the file, which looks like the issue you reported.

It's not clear from your description if you got the first prompt, to open with cloud viewer. Could you please add more details if the issue you are experiencing doesn't match my description? Thank you!

Devices: 
- LG G4 (Android 6.0)
- Huawei Honor 5X (Android 5.1.1)
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
status-firefox54: --- → affected
status-firefox55: --- → affected
status-firefox56: --- → affected
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → ARM
(Reporter)

Comment 4

10 months ago
when i click no, download is failing if i choose firefox for addon prompt.
if i click yes for cloud viewer, pdf is loading.

the steps given by you are exactly similar to me.
Andy, from the description above, this seems related to the addon installed. Is this something your team is able to take a look at? Or this should be handled by the addon developer?

Thanks.
Component: General → Add-on Manager
Flags: needinfo?(amckay)

Comment 6

9 months ago
In this case we would attempt to contact the add-on author and let them know and address the issue. 

If there's a bug in Firefox code that can be figured out from this, then we'd file a bug on it. Since this add-on is not a WebExtension, it would get prioritized accordingly.

The add-on in question is https://addons.mozilla.org/en-US/android/addon/cloud-viewer/ and created by Mark Finkle, so I've cc'd him on the bug.
Flags: needinfo?(amckay)

Updated

9 months ago
tracking-fennec: ? → -
[traige@0719] Thanks Andy's information. I'll - it.

Comment 8

7 months ago
Marking as won't fix so it won't show up in the Firefox 57 triage. This is up to the add-on author to fix. By Firefox 57 this won't be a valid add-on because its not a WebExtension.
status-firefox57: --- → wontfix

Comment 9

3 months ago
Due to Firefox 57, this issue is no longer valid.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.