Background image is not visible in Composer after publishing.

RESOLVED DUPLICATE of bug 167262

Status

SeaMonkey
Composer
P3
normal
RESOLVED DUPLICATE of bug 167262
16 years ago
13 years ago

People

(Reporter: TucsonTester1, Unassigned)

Tracking

({qawanted})

Trunk
Future
x86
Windows XP
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1)
Gecko/20020413 Netscape6/6.2.1+
BuildID:    2002041306

If a background image is applied to a previously published page and then
published, the background image is not visible in Composer.

Reproducible: Always
Steps to Reproduce:
1.Install/Launch NS.
2.Launch new/blank Composer window.
3.Enter some content and publish page to ftp site(file|publish as...).
4.Add a background image... Format|Page colors and background, choose background
image.
5.Publish page.

Actual Results:  The background image disappears from the open Composer window
as the page publishes.

Expected Results:  The background image should remain visible within the normal
edit mode in Composer.

Although the background image is not visible in the normal edit mode of
Composer, it does upload when the page is published.  The background image is
also visible when browsing the page and is apparent in <HTML>Source mode
"...background=image.jpg".

Comment 1

16 years ago
I can't reproduce this -- background image file displays after it uploads.
Was the image file a local image? Was "Include images and other files" checked 
in the publish dialog?

(Reporter)

Comment 2

16 years ago
Step 3 should have specified to add and publish an image.

I'm still seeing the bug on build 2002041603
in both XP and 98SE.
(Reporter)

Comment 3

16 years ago
Another addendum to the steps to reproduce.  It seems the bug only appears when
"Always show Publish dialog when publishing page" is checked in the Composer
preferences window (edit|preferences).  

Comment 4

16 years ago
I am able to reproduce this problem on Win 2k using the 4-15 1.0.0 build, though
it does not happen everytime.

My steps:
1. Launch Composer 
2. Click on Edit - Preferences, and make sure it is set to always show the
publish dialog
3. Go back into Composer, and create a page with a little bit of text, and one
image (I used a gif).
4. Publish the page to a valid FTP location, make sure the corresponding "HTTP
address to browse to" is also filled in, and have the image uploaded into the
same directory as the page.
5. Close out of the publish progress dialog
6. Add a background image to the page (I used a different gif)
7. Click on the Publish Icon on the toolbar
8. Click on the Publish button from the publish dialog 
9. Close out of the publish progress dialog again

Notice that the background image is gone from Composer's normal view.  However,
switching from HTML source to Show All Tags to Normal view will usually bring it
back.  And the background image is visible if you browse to the page.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
I still can't reproduce this. But if it does exist, it is a layout redraw problem,
not a publishing problem. Switching to source view and back confirms this.
Note that after publishing, we change the doc URL to the publishing location
and the page is effectively reloaded, so that's where the redisplay of page
is triggered.
Assignee: cmanske → attinasi
Component: Editor: Composer → Layout
QA Contact: sujay → petersen

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 6

15 years ago
The source created by marking the checkbox for making URL relative to current location doens't work.  The reference points to local file:// fully qualified windoes filename, regardless.  So, uploaded, obviously the host can't find the background image.  The scary thing is that modifying the source code in the source tab doesn't 'take', either!!

Comment 7

15 years ago
-->Editor: Composer

Warren Severin--what version of mozilla are you seeing this problem with?  Can
you attach a version of the file you see problems with or list reproducible steps?
Assignee: attinasi → composer
Component: Layout → Editor: Composer
Keywords: qawanted
QA Contact: petersen → sujay

Comment 8

15 years ago
I can help... (I've figured out what's wrong, and have a workaround)

The problem is that Composer is not generating a RELATIVE URL designation for
the background file, regardless of the setting in the dialog.

The generated HTML (style tag) contains:
   url(file:///d:/main_path/image_subdir/filename.ext)
Instead, it should generate:
   url(image_dir/filename.ext)

It works on YOUR system during preview, since the full path can be resolved.
However, when viewing from another system, the full path cannot be resolved.

Workaround:

After saving a page with a (relative-path) background image, and BEFORE
publishing, manually edit the HTML, and remove the "file:///d:/main_path/"
string, leaving:  url(image_subdir/filename.ext)

Comment 9

15 years ago
I'm not in a position to decide on this, but we might mark this as duplicate of
167262. This shows so-called workarounds, etc.
Product: Browser → Seamonkey

Comment 10

13 years ago
like udippel said, this is a dupe of "style element background-image: composer
makes relative links absolute".  it's been fixed for a while.

*** This bug has been marked as a duplicate of 167262 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.