Closed Bug 1376160 Opened 7 years ago Closed 7 years ago

Provide a synchronous global storage API accessible through content scripts in WebExtensions.

Categories

(WebExtensions :: General, enhancement)

54 Branch
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1332273

People

(Reporter: giwayume, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170608175746

Steps to reproduce:

I'm trying to write a script manager using Web Extensions. The problem I'm running to is there isn't a way to reliably inject user scripts on to the page at document start, due to the asynchronous nature of the browser.storage API ya'll ripped from Chrome. I can solve this problem with some sort of synchronous global storage accessible to content scripts on all pages across all websites.
Severity: normal → enhancement
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.