Closed Bug 1376243 Opened 4 years ago Closed 4 years ago

glterrain causes a device reset when Advanced Layers is enabled

Categories

(Core :: Graphics: Layers, defect)

40 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: dvander, Assigned: dvander)

References

Details

Attachments

(1 file)

This test has a history of being a bit flaky, and is currently a bit flaky on Windows 10. But with AL it quite reliably has a new failure mode of what might be a driver reset, and manifests in shaders not compiling with E_OUTOFMEMORY. Example try run:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=32a3c9496ff2af8f5a9b5cf451dd46ed3dca4d2a
I can reproduce this on my Win8 loaner. Looks like OpenSharedHandle is returning E_OUTOFMEMORY so we force a device reset.
Attached patch bug1376243.patchSplinter Review
The bug is that AL was not flushing unused TextureHosts, so WebGL was allocating more until the compositor process ran out of memory (either in D3D11 or jemalloc, whichever came first).
Attachment #8881458 - Flags: review?(matt.woodrow)
Attachment #8881458 - Flags: review?(matt.woodrow) → review+
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/37208b6123a1
Fix not flushing unused TextureHosts in Advanced Layers. (bug 1376243, r=mattwoodrow)
https://hg.mozilla.org/mozilla-central/rev/37208b6123a1
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.