complete loss of email

VERIFIED WORKSFORME

Status

MailNews Core
Backend
--
critical
VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Myrddin Emrys, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020414
BuildID:    2002041408

I fired up the browser and opened the email client to find all of it gone...
inbox,sent,everything. After some digging I located at least some in another
location. Evidently it decided to create another folder to use so, starting from
scratch all was empty. This has happened twice now. Once in 0.9.9 in the main,
downloadable build and again in the build from 14 April 2002. I have made backup
copies of the folders, created my own location to use and have it up again
without too much loss.

Reproducible: Didn't try
Steps to Reproduce:
1. not related to url, happens on its own.

I scanned all files on the system for virus as is my habit, none present. No
idea when this occurs or what triggers it. I have five email addresses in this
profile. From now on until I hear its fixed I am going to make backup copies
after exiting and finding that filesizes haven't already gone to zero or indexes
to initial 'empty' sizes.
(Assignee)

Comment 1

16 years ago
you've probably been bitten by the prefs corruption bug where your local mail
directory gets changed/corrupted. If you look at the local directory under your
pop account server settings, what directory is specified? My guess is that in
your prefs.js, there's garbage, and that this is a dup of bug 131688  - your
mail isn't lost, it's that mozilla has lost the path of the directory where it's
stored.
Component: Mail Database → Mail Back End

Comment 2

16 years ago
Resolving as we never heard back from reporter regarding queries in comment 1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 3

16 years ago
marking verified worksforme/duplicate of bug 131688.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.