Installation of many Google PWAs fails

RESOLVED WORKSFORME

Status

()

Firefox for Android
Web Apps
P1
normal
RESOLVED WORKSFORME
a year ago
5 months ago

People

(Reporter: Jovan Gerodetti, Unassigned)

Tracking

(Blocks: 1 bug)

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
When trying to add PWAs like Google Photos or Google Contacts to the home screen, the "installation" fails with this error:

> Failed to install: Could not find valid icon

This happens because installManifest() looks for an icon of the size 144 and Googles manifest doesn't offer this exact size. Google Photos for example offers icons in the sizes, 192, 128, 96 and 64. 

It would be better to look for the size that is closest to what is required and not just abort the installation.
Priority: -- → P1
(Reporter)

Comment 1

5 months ago
Both Google Photos and Google Contacts can be installed now.

Comment 2

5 months ago
Works for me too on Nightly 60 (2018-02-12). 
Device: Sony Xperia Z5 Premium (Android 6.0.1)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.