Crash in mozilla::dom::FetchBodyConsumer<T>::BeginConsumeBodyMainThread

RESOLVED DUPLICATE of bug 1375749

Status

()

Core
DOM
--
critical
RESOLVED DUPLICATE of bug 1375749
a year ago
11 months ago

People

(Reporter: calixte, Unassigned)

Tracking

(Blocks: 1 bug, {crash, regression})

56 Branch
Unspecified
Windows 10
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

Details

(Whiteboard: [clouseau], crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-3f5f3c5b-f725-403d-8fc1-1f28f0170623.
=============================================================

There are 27 crashes in nightly 56, they started with buildid 20170621102301. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1373555.

[1] https://hg.mozilla.org/mozilla-central/rev?node=f5b120a0b4803033a50a51280feef824021ba574
Flags: needinfo?(amarchesini)
Crash Signature: [@ mozilla::dom::FetchBodyConsumer<T>::BeginConsumeBodyMainThread] → [@ mozilla::dom::FetchBodyConsumer<T>::BeginConsumeBodyMainThread] [@ mozilla::dom::FetchBodyConsumer<T>::ContinueConsumeBlobBody] [@ mozilla::dom::FetchBodyConsumer<T>::ContinueConsumeBody]
Crash Signature: [@ mozilla::dom::FetchBodyConsumer<T>::BeginConsumeBodyMainThread] [@ mozilla::dom::FetchBodyConsumer<T>::ContinueConsumeBlobBody] [@ mozilla::dom::FetchBodyConsumer<T>::ContinueConsumeBody] → [@ mozilla::dom::FetchBodyConsumer<T>::BeginConsumeBodyMainThread] [@ mozilla::dom::FetchBodyConsumer<T>::ContinueConsumeBlobBody] [@ mozilla::dom::FetchBodyConsumer<T>::ContinueConsumeBody] [@ mozilla::dom::Promise::MaybeSomething<T>]
Bug 1374922 should fix it.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1374922
This is still top #19 of Nightly 20170625030210, e.g., bp-8e51c136-5de6-48fb-8f82-ab2fc0170627.
Status: RESOLVED → REOPENED
Flags: needinfo?(amarchesini)
Resolution: DUPLICATE → ---
Crash Signature: [@ mozilla::dom::FetchBodyConsumer<T>::BeginConsumeBodyMainThread] [@ mozilla::dom::FetchBodyConsumer<T>::ContinueConsumeBlobBody] [@ mozilla::dom::FetchBodyConsumer<T>::ContinueConsumeBody] [@ mozilla::dom::Promise::MaybeSomething<T>] → [@ mozilla::dom::FetchBodyConsumer<T>::BeginConsumeBodyMainThread] [@ mozilla::dom::FetchBodyConsumer<T>::ContinueConsumeBlobBody] [@ mozilla::dom::FetchBodyConsumer<T>::ContinueConsumeBody] [@ mozilla::dom::Promise::MaybeSomething<T>] [@ mozil&hellip;
I landed a patch today for fixing this bug.
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1375749
Fixed in 56 in the duplicate bug.
status-firefox56: affected → fixed
Blocks: 1396527
You need to log in before you can comment on or make changes to this bug.