All users were logged out of Bugzilla on October 13th, 2018

Determine why python_mozetl/tests/test_pulse.py fails on Travis

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: spenrose, Assigned: harter)

Tracking

Details

(Reporter)

Description

a year ago
This diff was necessary to get tests to pass on Travis-CI. It is incorrect code and fails (as it should) on developer machines.

--- a/tests/test_pulse.py
+++ b/tests/test_pulse.py
@@ -75,10 +75,10 @@ def test_simple_transform(row_to_dict, simple_rdd, spark_context):
         'version': u'1.0.2',
         'requests': requests,
         'disconnectRequests': 1,
-        'consoleErrors': 0,
+        'consoleErrors': None,
         'e10sStatus': 1,
         'e10sProcessCount': 4,
-        'trackingProtection': False
+        'trackingProtection': None
     }

Comment 1

a year ago
Ryan, do you know why this test might be failing?
Flags: needinfo?(rharter)
(Assignee)

Updated

a year ago
Assignee: nobody → rharter
Flags: needinfo?(rharter)
(Assignee)

Comment 2

a year ago
That's very weird. I have a suspicion these tests aren't being run with tox since flake8 is not being run either. I have a PR started here [1] that re-breaks these tests.

[1] https://github.com/mozilla/python_mozetl/pull/56
(Assignee)

Updated

a year ago
Points: --- → 1
Priority: -- → P1
(Assignee)

Comment 3

a year ago
I'm going to pause on this until Anthony gets these tests dockerized. Hopefully that fixes everything.
Component: Datasets: Telemetry Aggregates → Datasets: General
(Assignee)

Comment 4

a year ago
This was fixed with dockerization.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.