All users were logged out of Bugzilla on October 13th, 2018

Text not displayed on google login form while typing email and password.

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
a year ago
2 months ago

People

(Reporter: dineshbhattrai0, Unassigned)

Tracking

unspecified
Unspecified
Linux

Firefox Tracking Flags

(firefox57 wontfix)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170612121707

Steps to reproduce:

Open google login form and type email and password


Actual results:

Typed email/password is not shown in email/password field. But it can be seen when typed text is selected.


Expected results:

Typed text should be visible as I type
Component: Untriaged → Layout: Form Controls
OS: Unspecified → Linux
Product: Firefox → Core
Priority: -- → P3
I can't reproduce on the latest version. Please confirm if it still occurs.
Flags: needinfo?(dineshbhattrai0)
(Reporter)

Comment 2

a year ago
I'm currently on nightly and the problem still persists. I don't know about stable version of firefox.
Flags: needinfo?(dineshbhattrai0)
Is this the Google Login form you're talking about: https://accounts.google.com/signin/v2/identifier ?  (That's where I get taken if I click "sign in" at the top right of google.com)

I can't reproduce this bug either, using Nightly on that page -- and I expect we'd be getting a lot more complaints from Nightly users if this were a common problem, so my initial suspicion is that the issue might be be a bad interaction with some add-on, or some other problematic/stale piece of configuration that ended up in your Firefox user profile.

Can you try a brand new Firefox user-profile and see if it reproduces there? You can find information on how to do that here:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles#w_creating-a-profile
Flags: needinfo?(dineshbhattrai0)
status-firefox57: --- → wontfix
(Reporter)

Comment 4

a year ago
I tried with a new profile. And the result is consistent with new google signin page. However it works fine with old one. I'm not sure if you are getting new signin page or the old one. The problem seems to be with the new signin page with firefox.
Flags: needinfo?(dineshbhattrai0)
Thanks.  Can you provide URLs for the new (broken) & old (working) sign-in pages that you're referring to?  A screenshot of the broken page might be helpful, too, to be sure we're testing the same site as you.
Flags: needinfo?(dineshbhattrai0)
(Reporter)

Comment 6

a year ago
Here is the screenshot: https://drive.google.com/open?id=0B9xG2I0X9DLgdWdMb1U0WF8yd1U
Flags: needinfo?(dineshbhattrai0)
Thanks. Can you load this page...
  https://jsfiddle.net/hemes7ae/
...and tell me what you see in the bottom-right results box?

(In particular, what color is the "hello" text and what color is that text's background?)
(I am guessing that you have a "dark" system theme applied, which makes the "hello" text there white (or lightish), and the background dark.)

I can reproduce a version of this bug, if I install and apply the "Arc-Dark" theme (from the arc-theme package) on my Ubuntu 17.10 system.

The issue here is:
 - you have a system theme that makes <input> elements light-text-on-dark-background
 - Firefox honors that with its default widget styling.
 - Google is overriding the default background-color on this widget on its login page, but they are not overriding the text color.  (They give it "background-color: transparent" and place it on top of a white element, so it's basically got a white background.)

So, the fault here is with Google's login page -- it's busted for them to specify a nondefault background color for this widget without *also* specifying a foreground color, because they have no guarantee that the user's default foreground will be OK on top of their specified background.

They get this right on other pages, e.g. the main https://www.google.com/ search page. On that page, they make the searchfield transparent, and they *also* give it "#lst-ib { color: #000; }" which sets the foreground color to black.

I'm reclassifying this as Tech Evangelism (which we use for website bugs that require some outreach), and I'll email our mozilla-google bug-discussion-list about this.
Status: UNCONFIRMED → NEW
Component: Layout: Form Controls → Desktop
Ever confirmed: true
Product: Core → Tech Evangelism
(I emailed Mozilla's discussion list with Google to report the issue to them.)
(Reporter)

Comment 10

a year ago
Thanks Daniel.
My Google contact says they've landed a fix for this on their end -- and I tested locally, and it does seem fixed to me.

Dinesh, could you verify on your end that this is fixed for you? Thanks!
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(dineshbhattrai0)
Resolution: --- → FIXED
(Reporter)

Comment 12

a year ago
Yeah, it's fixed now. Thanks.
Flags: needinfo?(dineshbhattrai0)
(Reporter)

Updated

a year ago
Status: RESOLVED → VERIFIED
See Also: → bug 1483617
You need to log in before you can comment on or make changes to this bug.