Color the titlebar in customize mode on macOS

VERIFIED FIXED in Firefox 56

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Gijs, Assigned: nhnt11)

Tracking

({regression})

55 Branch
Firefox 56
Unspecified
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed, firefox57 verified)

Details

(Whiteboard: [photon-visual][p3])

Attachments

(2 attachments)

Reporter

Description

2 years ago
Just like bug 1375973, in customize mode the title bar is also transparent/light, and as a result you can't read the text in background tabs.

Comment 1

2 years ago
This seems to be WFM now on latest Nightly (macOS).
Reporter

Comment 2

2 years ago
(In reply to Robin Whittleton from comment #1)
> This seems to be WFM now on latest Nightly (macOS).

Yes, though the titlebar is still not dark - Johann, is that intentional?
Flags: needinfo?(jhofmann)
Not on a Mac right now, I'll let Nihanth figure this out since he was working on Mac titlebar coloring.
Flags: needinfo?(jhofmann) → needinfo?(nhnt11)
Reporter

Updated

2 years ago
See Also: → 1379981
Reporter

Updated

2 years ago
Summary: Titles of background tabs are unreadable (light on light) in customize mode → In customize mode the tabstrip thinks it has a dark background (gets light icons) even though it doesn't
Reporter

Comment 4

2 years ago
FWIW, I suspect this is a function of the caching implemented in bug 1334642 and/or us not calling inferFromText() again when entering/leaving customize mode.
Reporter

Updated

2 years ago
Whiteboard: [photon-visual][triage]
OS: Unspecified → Mac OS X
Flags: qe-verify+
Priority: -- → P2
QA Contact: brindusa.tot
Whiteboard: [photon-visual][triage] → [photon-visual]
Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Priority: P2 → P1
Whiteboard: [photon-visual] → [photon-visual][p3]
Iteration: --- → 56.3 - Jul 24
Comment hidden (mozreview-request)
Assignee

Comment 6

2 years ago
Coloured titlebar in customize mode used to look ugly but now it's fine, we should do it.
Flags: needinfo?(nhnt11)
Summary: In customize mode the tabstrip thinks it has a dark background (gets light icons) even though it doesn't → Color the titlebar in customize mode on macOS

Comment 7

2 years ago
mozreview-review
Comment on attachment 8887709 [details]
Bug 1376413 - Color the titlebar in customize mode on macOS.

https://reviewboard.mozilla.org/r/158612/#review164028
Attachment #8887709 - Flags: review?(dao+bmo) → review+

Comment 8

2 years ago
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/058760087ee4
Color the titlebar in customize mode on macOS. r=dao
https://hg.mozilla.org/mozilla-central/rev/058760087ee4
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Assignee

Updated

2 years ago
Duplicate of this bug: 1379981
See Also: 1379981

Comment 11

2 years ago
Verified on latest Nightly Version 57.0a1 Build ID  20170811100330
As can be seen in the screenshot, the colour is still displayed as white with light grey text as Gijs commented:
> Just like bug 1375973, in customize mode the title bar is also
> transparent/light, and as a result you can't read the text in background
> tabs.

Is this intended ?Thank you
Flags: needinfo?(nhnt11)
QA Contact: brindusa.tot → ovidiu.boca
Assignee

Comment 12

2 years ago
(In reply to Deac Alin from comment #11)
> Created attachment 8896250 [details]
> Screen Shot 2017-08-11 at 15.43.47.png
> 
> Verified on latest Nightly Version 57.0a1 Build ID  20170811100330
> As can be seen in the screenshot, the colour is still displayed as white
> with light grey text as Gijs commented:
> > Just like bug 1375973, in customize mode the title bar is also
> > transparent/light, and as a result you can't read the text in background
> > tabs.
> 
> Is this intended ?Thank you

I can't reproduce this anymore, can you please check and if it's still a problem, provide STR?
Flags: needinfo?(nhnt11)

Comment 13

2 years ago
(In reply to Nihanth Subramanya [:nhnt11] from comment #12)
> I can't reproduce this anymore, can you please check and if it's still a
> problem, provide STR?

The issue here is that the colour of the Title bar is not consistent when in normal screen mode vs Full screen mode. Also when checking/unchecking the Title bar box. My question, if this is intended, was around this scenario.

1. Open Nightly and go to Customize - Default theme
2. Check the Title bar box (observe the color of the Bar)
3. Uncheck the Title bar
4. Adjust to full screen by pressing the button on top right side
5. Check the title bar box

Updated

2 years ago
Flags: needinfo?(nhnt11)

Comment 14

2 years ago
Hi Nihanth, did you get the chance to look at this? Thank you

Comment 15

2 years ago
Retested on the latest Nightly and cannot reproduce the issue anymore on Mac 10.12.5 . I will mark this as Verified Fixed. Thank you
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(nhnt11)
You need to log in before you can comment on or make changes to this bug.