Tabs turn into empty white screen with spinner with e10s-multi enabled

RESOLVED DUPLICATE of bug 1383156

Status

()

RESOLVED DUPLICATE of bug 1383156
2 years ago
a year ago

People

(Reporter: bugzilla+mozilla, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170619141703

Steps to reproduce:

Whenever I resume my computer from suspend, the tabs I had loaded in Firefox turn into a white screen with an ajax spinner in the centre.  I believe this is related to e10s-multi.  It seems to have started only since upgrading to FF55.  If I open a new tab, it works fine—I can go to any site.  But if I try to reload or enter a new URL into one of these "dead" tabs, nothing happens.  It just stays on the spinner indefinitely.  Restarting Firefox restores the tabs correctly.

I have tried reducing the content processes by setting dom.ipc.processCount to 1, but it has had no apparent effect.

I'm currently running FF Developer Edition 55.0b3 64-bit on Ubuntu 17.04.
(Reporter)

Comment 1

2 years ago
Update: this actually seems to happen whenever gnome-shell is killed/restarts.  In the most recent case, it was killed due to having too many files open.
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Firefox: 55.0b5, Build ID: 20170626235638

I have tested this issue with Developer Edition 55.0b5 x64 on Ubuntu 16.04 and also on 14.04, but I haven't managed to reproduce it. After resuming from suspend, all the opened tabs were correctly displayed and I was able to enter a new URL in any tab.

Ryan, can you please test if the issue is reproducible on latest Nightly (56.0a1) build? Also can you retest the issue using a new clean profile to eliminate custom settings as a possible cause (https://goo.gl/AR5o9d)?
Flags: needinfo?(bugzilla+mozilla)
Marking this as Resolved - Incomplete due to the lack of response from the reporter.
If anyone can still reproduce it on latest versions, feel free to reopen the issue and provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

a year ago
Apologies for the delayed response.  I can still reproduce this with the latest nightly 56.0a1 (2017-07-23), using a clean profile.  The issue occurs as soon as gnome-shell is killed.  The issue does go away when I disable e10s, but not if I use a single content process.  Hardware acceleration setting has no effect.  I did not notice this issue previously with e10s, which I have had enabled for some time now.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(bugzilla+mozilla)
Resolution: INCOMPLETE → ---
(Reporter)

Comment 5

a year ago
I just tried Firefox 54.0 (Ubuntu package, build ID 20170612121707) and can confirm that this does *not* happen, even with e10s enabled (Confirmed in about:support).

I tried debugging the content process in gdb while I restarted gnome-shell, but it never died or gave any useful information.
Bug 1382292 has the tracking flags set and a regression window so duping forward.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1382292
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Er 1383156
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1383156

Comment 8

a year ago
(In reply to Cosmin Muntean [:CosminMCG], Desktop Engineering QA from comment #2)
> User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101
> Firefox/55.0
> Firefox: 55.0b5, Build ID: 20170626235638
> 
> I have tested this issue with Developer Edition 55.0b5 x64 on Ubuntu 16.04
> and also on 14.04, but I haven't managed to reproduce it. After resuming
> from suspend, all the opened tabs were correctly displayed and I was able to
> enter a new URL in any tab.
> 
> Ryan, can you please test if the issue is reproducible on latest Nightly
> (56.0a1) build? Also can you retest the issue using a new clean profile to
> eliminate custom settings as a possible cause (https://goo.gl/AR5o9d)?

Hi. Just a note from someone who has been testing Linux software for two decades. You have to replicate the user's environment including the Window manager. Software (namely X11 applications) can behave differently under different for example under (compiz) ubuntu than (gnome-shell) gnome because those window managers draw things differently.
Some issues will appear under both window managers. Some won't. Kwin is closer to gnome-shell in this regard.
xfwm4 and compiz are unlikely to trigger this issue.
You need to log in before you can comment on or make changes to this bug.