Stub installer header text cut off in some locales

VERIFIED FIXED in Firefox 55

Status

()

defect
P2
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: mhowell, Assigned: mhowell)

Tracking

unspecified
Firefox 56
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox55 verified, firefox56 verified)

Details

Attachments

(1 attachment)

According to bug 1375013 comment 9, the stub installer header (the "Now installing" text) is flowing to a second line on certain locales, but the second line appears underneath the progress bar and isn't readable.

It looks like that text isn't being given the full width of the window, so I think we can fix the issue just by correcting that oversight.
Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Comment on attachment 8881481 [details]
Bug 1376489 - Allow stub installer header text to use the full window width.

https://reviewboard.mozilla.org/r/152604/#review157824
Attachment #8881481 - Flags: review?(robert.strong.bugs) → review+
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e5aa4678b802
Allow stub installer header text to use the full window width. r=rstrong
Comment on attachment 8881481 [details]
Bug 1376489 - Allow stub installer header text to use the full window width.

Approval Request Comment
[Feature/Bug causing the regression]:
Bug 1365998

[User impact if declined]:
"Now installing" text in stub installer is cut off in some locales. See screenshots in bug 1375013 comment 9.

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
Not yet.

[Needs manual test from QE? If yes, steps to reproduce]: 
Yes, since this was found during manual testing on bug 1375013, the same test should be done to verify this fix. Quoting from there: "QA should run the stub installer, look at the footer text (the text to the right of the logo), verify that it is entirely visible/legible, and then just immediately close the installer again. This should be done for all locales if possible, and at different DPI scaling settings."

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
This is a tiny cosmetic change. I've verified the fix for en-US and for hu, so I'm highly confident in it, and manual testing can get us the rest of the way there.

[String changes made/needed]:
None
Attachment #8881481 - Flags: approval-mozilla-beta?
Flags: qe-verify?
https://hg.mozilla.org/mozilla-central/rev/e5aa4678b802
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Camelia, can you help verify?
Flags: qe-verify?
Flags: qe-verify+
Flags: needinfo?(camelia.badau)
Comment on attachment 8881481 [details]
Bug 1376489 - Allow stub installer header text to use the full window width.

stub installer fix, beta55+
Attachment #8881481 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I've tested on Windows 7 x64 and Windows 10 x86 using latest Nightly 56.0a1 (2017-06-29), all locales, DPI 100% and DPI 150% and the stub installer looks good now.

Please see here the testing report: https://public.etherpad-mozilla.org/p/bug1376489

I will test on Firefox 55 and I will follow up with test results.
Flags: needinfo?(camelia.badau)
I've tested on Windows 7 x64 and Windows 10 x86 using Firefox 55 Beta 6 (20170629005143), all locales, DPI 100% and DPI 150% and the stub installer looks good.

Please see here the testing report: https://public.etherpad-mozilla.org/p/bug1376489
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.