Logs show incorrect handling of null hostname in nsHostResolver::ResolveHost

RESOLVED INVALID

Status

()

RESOLVED INVALID
a year ago
a year ago

People

(Reporter: valentin, Assigned: valentin)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-active])

(Assignee)

Description

a year ago
The logs in attachment 8879880 [details] show:

[ProxyResolution]: D/nsHostResolver Resolving host [null].
[ProxyResolution]: D/nsHostResolver   No usable address in cache for host [null].

However, that method should return if host is null:

NS_ENSURE_TRUE(host && *host, NS_ERROR_UNEXPECTED);
http://searchfox.org/mozilla-central/rev/b425854d9bbd49d5caf9baef3686e49ec91c17ec/netwerk/dns/nsHostResolver.cpp#737


I'm not sure this is the cause of bug 1174249, but it seems a weird behaviour.
(Assignee)

Comment 1

a year ago
I just seem to have misread the logs. The string in the logs is "null", not "(null)", so this is just some webpage trying to resolve "null" as a host. Weird, but not a bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.