StatCounter ignores Firefox mobile

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
a year ago
11 months ago

People

(Reporter: will69, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sitewait])

(Reporter)

Description

a year ago
StatCounter identifies Firefox mobile and tablet user agents as "desktop".

STR:

Go to https://www.guitar-online.com/ with Firefox for Android (mobile or tablet)
Go to http://statcounter.com/demo/pageload/
Find Firefox entry marked with "You"
Switch to details view (looking glass)

Firefox for Android is identified as:

Browser: Firefox 54.0
OS/Platform: Unknown/Desktop

Expected result:

Browser: Firefox 54.0
OS/Platform: Unknown/Mobile

Or:

Browser: Firefox 54.0
OS/Platform: Unknown/Tablet

Here are the respective user agent strings:

Mozilla/5.0 (Android 4.4.4; Mobile; rv:54.0) Gecko/54.0 Firefox/54.0
Mozilla/5.0 (Android 4.4.4; Tablet; rv:54.0) Gecko/54.0 Firefox/54.0

This may very well skew your complete mobile market share on http://gs.statcounter.com, the largest provider of free web statistics with country breakdown.
(Reporter)

Comment 1

a year ago
StatCounter has indicated they are going to update their detection.
Cool. Thanks for reporting AND doing the outreach, will69! Highly appreciated. :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [sitewait]
(Reporter)

Comment 3

a year ago
Here is an easier way to reproduce the problem: http://gs.statcounter.com/detect .
Seems like this is not fixed. The test page from comment 3 still pretends that my mobile browser is a desktop browser.
will69, is there anything new? If not, do you mind forwarding the email you sent to statcounter.com so I can follow up? Maybe a @mozilla.com email address does some wonders.
Flags: needinfo?(will69)
(Reporter)

Comment 6

a year ago
Dennis, I have forwarded the email to your PM. This really needs to be fixed.
Flags: needinfo?(will69)
Seems like this is not yet fixed. curious if you've heard anything new? Thanks
Flags: needinfo?(will69)
Flags: needinfo?(dschubert)
I reached out to StatCounter's CEO a while back.  I have not heard back.  
I will try reaching out again.
(Reporter)

Comment 9

a year ago
Aodhan Cullen confirmed they were going to update their detection on 2017-06-23. I never heard of him again. Nor did he make good on his promise. I have since used their web interface (above) to report other inaccuracies, to no avail.
Flags: needinfo?(will69)
Forwarding this to Adam, he told me they are also in contact.
Flags: needinfo?(dschubert) → needinfo?(astevenson)
Thanks Dennis! Looks like Peter has it covered here.
Flags: needinfo?(astevenson)
(Reporter)

Comment 12

11 months ago
StatCounter has fixed this for Firefox mobile and tablet user agent strings on http://gs.statcounter.com/detect as well as https://statcounter.com/demo/pageload. Thanks Aodhan!
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.