Call Destroy() from LayerTransactionParent::ActorDestroy()

RESOLVED FIXED in Firefox 56

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: sotaro, Assigned: sotaro)

Tracking

unspecified
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
To handle abnormal shutdown case, we need to call Destroy() from ActorDestroy().
(Assignee)

Updated

a year ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 1

a year ago
Created attachment 8881875 [details] [diff] [review]
patch - Call Destroy() from LayerTransactionParent::ActorDestroy()
(Assignee)

Updated

a year ago
Attachment #8881875 - Flags: review?(nical.bugzilla)
Attachment #8881875 - Flags: review?(nical.bugzilla) → review+

Comment 3

a year ago
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fa03375be18d
Call Destroy() from LayerTransactionParent::ActorDestroy() r=nical

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fa03375be18d
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
(Assignee)

Updated

a year ago
Blocks: 1376896
(Assignee)

Comment 5

a year ago
Comment on attachment 8881875 [details] [diff] [review]
patch - Call Destroy() from LayerTransactionParent::ActorDestroy()

Approval Request Comment
[Feature/Bug causing the regression]: The problem exists since Bug 825928, but it does not cause a harm by itself. The change is necessary for Bug 1376896.
[User impact if declined]:It is necessary for Bug 1376896. If Bug 1376896 is not up lifted, it could cause memory leak.
[Is this code covered by automated tests?]: passed try and land in central for a while
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: This is necessary for Bug 1376896.
[Is the change risky?]: Low risk
[Why is the change risky/not risky?]: The change just added shut down handling to ActorDestroy(). LayerTransactionParent::Destroy() is already used for a long time.
[String changes made/needed]: None
Attachment #8881875 - Flags: approval-mozilla-beta?
Comment on attachment 8881875 [details] [diff] [review]
patch - Call Destroy() from LayerTransactionParent::ActorDestroy()

same as bug 1376896
Attachment #8881875 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.