Closed Bug 1376915 Opened 2 years ago Closed 2 years ago

Crash in shutdownhang | NtWaitForAlertByThreadId | RtlSleepConditionVariableSRW | SleepConditionVariableSRW

Categories

(Core :: General, defect, critical)

56 Branch
Unspecified
Windows
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1371248
Tracking Status
firefox55 --- unaffected
firefox56 --- fixed

People

(Reporter: philipp, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-c546b7b4-7427-4045-8cef-6044d0170627.
=============================================================
Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	ntdll.dll 	NtWaitForAlertByThreadId 	
1 	ntdll.dll 	RtlSleepConditionVariableSRW 	
2 	kernelbase.dll 	SleepConditionVariableSRW 	
3 	mozglue.dll 	mozilla::detail::ConditionVariableImpl::wait(mozilla::detail::MutexImpl&) 	mozglue/misc/ConditionVariable_windows.cpp:58
4 	xul.dll 	mozilla::CondVar::Wait(unsigned int) 	obj-firefox/dist/include/mozilla/CondVar.h:68
5 	xul.dll 	nsEventQueue::GetEvent(bool, nsIRunnable**, mozilla::BaseAutoLock<mozilla::Mutex>&) 	xpcom/threads/nsEventQueue.cpp:76
6 	xul.dll 	nsThread::nsChainedEventQueue::GetEvent(bool, nsIRunnable**, unsigned short*, mozilla::BaseAutoLock<mozilla::Mutex>&) 	xpcom/threads/nsThread.cpp:836
7 	xul.dll 	nsThread::GetEvent(bool, nsIRunnable**, unsigned short*, mozilla::BaseAutoLock<mozilla::Mutex>&) 	xpcom/threads/nsThread.cpp:1294
8 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp:1377
9 	xul.dll 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/threads/nsThreadUtils.cpp:471
10 	xul.dll 	nsThreadManager::SpinEventLoopUntil(nsINestedEventLoopCondition*) 	xpcom/threads/nsThreadManager.cpp:347
11 	xul.dll 	XPTC__InvokebyIndex 	xpcom/reflect/xptcall/md/win32/xptcinvoke_asm_x86_64.asm:97
12 		@0x199489d25ff 	
13 	xul.dll 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:966
14 		@0x1d7ad1c3e6b

shutdownhangs with crash stacks similar like the one above with XPC_WN_CallMethod started appearing in 56.0a1 after build 20170622030208:
https://crash-stats.mozilla.com/signature/?product=Firefox&release_channel=nightly&_sort=-date&process_type=browser&signature=shutdownhang%20%7C%20NtWaitForAlertByThreadId%20%7C%20RtlSleepConditionVariableSRW%20%7C%20SleepConditionVariableSRW&date=%3E%3D2017-06-21T17%3A39%3A00.000Z&proto_signature=%7EXPC_WN_CallMethod#graphs

this would be the pushlog to the build of the day before:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e1e4a481b7e88dce163b9cccc2fb72032023befa&tochange=edb7e1ddd9b61e2af2a75cfe5baa0f92a54a2716
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1371248
Fixed in the duplicate.
You need to log in before you can comment on or make changes to this bug.