Closed Bug 1377002 Opened 4 years ago Closed 1 year ago

www.metrolyrics.com diaporama are broken with Tracking Protection

Categories

(Web Compatibility :: Desktop, defect, P3)

Firefox 62
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1226498

People

(Reporter: julienw, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-social][tp-content])

User Story

-facebook.net
-ajax.googleapis.com

Attachments

(1 file)

Prerequisite: use tracking protection (for example, you can use private browsing to enable it)

    Navigate to: http://www.metrolyrics.com/news-gallery-artists-who-want-trump-to-stop-using-their-music.html

Expected Behavior:
There are arrows besides the image so that we can browse the various songs.

Actual Behavior:
No arrows, so we can't browse the content.

The error seems to be that a facebook js file (http://connect.facebook.net/en_US/all.js) is blocked, requirejs returns an error to the JS code, and then stops loading anything else.
Keywords: DevAdvocacy
Priority: -- → P5
Whiteboard: tp-base
Component: Tracking Protection → Desktop
Keywords: DevAdvocacy
Priority: P5 → --
Product: Firefox → Tech Evangelism
Still happening.
Tested on 58.0a1 with TP enabled, verified arrows remain blocked on metrolyrics link.
Priority: -- → P5
Component: Desktop → Tracking Protection
Priority: P5 → P3
Product: Tech Evangelism → Firefox
Whiteboard: tp-base → tp-needsrepro
Still happening for me.
Attached image Screen Capture 2.gif
I am unable to reproduce this issue on Windows 10 and Nightly 63, with basic or Strict Tracking Protection enabled.

Julien, do you still encounter the issue?
Flags: needinfo?(felash)
Closing this as Worksforme.
Status: NEW → RESOLVED
Closed: 3 years ago
Component: Tracking Protection → Desktop
OS: Unspecified → Windows 10
Priority: P3 → --
Product: Firefox → Tech Evangelism
Hardware: Unspecified → x86_64
Resolution: --- → WORKSFORME
Whiteboard: tp-needsrepro
Version: unspecified → Firefox 62
I still see it in latest nightly, unfortunately...
I'm not sure what's different for you.
Status: RESOLVED → REOPENED
Flags: needinfo?(felash) → needinfo?(sergiu.logigan)
Resolution: WORKSFORME → ---
Mac 10.13 + Nightly 63 + Tracking protection [basic & strict] repros the issue - no arrows to navigate on the listed page http://www.metrolyrics.com/news-gallery-artists-who-want-trump-to-stop-using-their-music.html
Looks like my machine finally came to its senses. It's reproducible on my side too.

This is related to `trackingprotection` breakage #1101005

Looking at the devtools console, here are the blocked resources:

The resource at “http://www.googletagmanager.com/gtm.js?id=GTM-6QP2” was blocked because content blocking is enabled.[Learn More] news-gallery-artists-who-want-trump-to-stop-using-their-music.html
The resource at “http://c.evidon.com/sitenotice/425/metrolyrics/settings.js” was blocked because content blocking is enabled.[Learn More] news-gallery-artists-who-want-trump-to-stop-using-their-music.html
The resource at “http://b.scorecardresearch.com/b?c1=2&c2=17672685&c4=metrolyrics&ns__t=1534924218716&ns_c=UTF-8&c8=8%20Songs%20Donald%20Trump%20Tried%20To%20Ruin%20For%20You%20And%20The%20Bands%20That%20Tried%20To%20Stop%20Him%20%7C%20MetroLyrics&c7=http%3A%2F%2Fwww.metrolyrics.com%2Fnews-gallery-artists-who-want-trump-to-stop-using-their-music.html&c9=” was blocked because content blocking is enabled.[Learn More] news-gallery-artists-who-want-trump-to-stop-using-their-music.html
The resource at “http://connect.facebook.net/en_US/all.js” was blocked because content blocking is enabled.[Learn More] news-gallery-artists-who-want-trump-to-stop-using-their-music.html
The resource at “http://fast.cbsi.demdex.net/dest5.html?d_nsid=0#http%3A%2F%2Fwww.metrolyrics.com%2Fnews-gallery-artists-who-want-trump-to-stop-using-their-music.html” was blocked because content blocking is enabled.[Learn More] news-gallery-artists-who-want-trump-to-stop-using-their-music.html
The resource at “http://secure-us.imrworldwide.com/v60.js” was blocked because content blocking is enabled.[Learn More] news-gallery-artists-who-want-trump-to-stop-using-their-music.html
The resource at “http://js.agkn.com/prod/v0/tag.js” was blocked because content blocking is enabled.[Learn More] news-gallery-artists-who-want-trump-to-stop-using-their-music.html

So these are the domains to test:
www.googletagmanager.com
c.evidon.com
b.scorecardresearch.com
connect.facebook.net
fast.cbsi.demdex.net
secure-us.imrworldwide.com
js.agkn.com

I opened the URL in a fresh browser profile (Firefox Nightly 63, uMatrix installed, normal mode) and loaded the page. No "Next" button was displayed on the slideshow.

I disabled the Spoof Referrer option in uMatrix and then *WHITELISTED*:

-facebook.net
-ajax.googleapis.com

After this, Next button was displayed and functional.
The other resources didn't help.

http://prntscr.com/kljqmk

facebook.net can be found in the disconnect-blacklist.json, disconnect-entitylist.json and disconnect_mapping.py.
googleapis.com can be found in the disconnect-blacklist.json and disconnect-entitylist.json

So in conclusion:

facebook.net - Social = [tp-social]
ajax.googleapis.com - Content = [tp-content]
Flags: needinfo?(sergiu.logigan)
User Story: (updated)
Whiteboard: [tp-social][tp-content]
Priority: -- → P3
Product: Tech Evangelism → Web Compatibility

How did you know that "connect.facebook.net" is the cause?
Thank you

Prerequisite: use tracking protection (for example, you can use private
browsing to enable it)

Navigate to:

http://www.metrolyrics.com/news-gallery-artists-who-want-trump-to-stop-using-
their-music.html

Expected Behavior:
There are arrows besides the image so that we can browse the various songs.

Actual Behavior:
No arrows, so we can't browse the content.

The error seems to be that a facebook js file
(http://connect.facebook.net/en_US/all.js) is blocked, requirejs returns an
error to the JS code, and then stops loading anything else.

The image gallery arrows are indeed un-broken if I shim the Facebook SDK all.js as suggested in bug 1226498, so this is a dupe of that bug.

Status: REOPENED → RESOLVED
Closed: 3 years ago1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1226498
You need to log in before you can comment on or make changes to this bug.