Teach GCPolicy about Maybe

RESOLVED FIXED in Firefox 56

Status

()

enhancement
RESOLVED FIXED
2 years ago
2 months ago

People

(Reporter: Yoric, Assigned: Yoric)

Tracking

unspecified
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment)

We can't really use JS::Rooted<Maybe<T>> at the moment, which is annoying.

Let's fix this.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 3

2 years ago
mozreview-review
Comment on attachment 8882050 [details]
Bug 1377008 - Teach GCPolicy about Maybe;

https://reviewboard.mozilla.org/r/153128/#review158336

Looks good, and simpler than expected.
Attachment #8882050 - Flags: review?(jcoppeard) → review+

Comment 4

2 years ago
Pushed by dteller@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8aa702072b26
Teach GCPolicy about Maybe;r=jonco

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8aa702072b26
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Duplicate of this bug: 1275075
You need to log in before you can comment on or make changes to this bug.