Closed Bug 1377049 Opened 5 years ago Closed 5 years ago

Add pre-push and pre-commit version control hooks

Categories

(Firefox Build System :: Lint and Formatting, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1361972

People

(Reporter: ahal, Assigned: ahal)

Details

Attachments

(1 obsolete file)

There are currently some hooks for eslint hanging around the tree. But it would be nice if there were generic mozlint hooks that ran all the linters. I'd also like to provide some pre-push hooks as an alternative to pre-commit.
This patch obsoletes the eslintvalidate hooks, though if we want to remove them we'll need some kind of error message that includes the upgrade path.

Also by design, ./mach lint --workdir lints both staged and unstaged files in git. Maybe it needs some kind of mode that only lints the staged files?

I also haven't really tested the pre-push git hook as I don't feel like setting up cinnabar on my laptop. I'll do some testing when I get back from the work week (though it looks like it should work).
Summary: [mozlint] Add pre-push and pre-commit version control hooks → Add pre-push and pre-commit version control hooks
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1361972
Attachment #8882084 - Attachment is obsolete: true
Product: Testing → Firefox Build System
You need to log in before you can comment on or make changes to this bug.