Sporadic ES ReadTimeout errors in Travis

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: peterbe, Assigned: peterbe)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

2 years ago
The change that triggered this master travis build was totally unrelated.

Just in case that Travis build disappears (see URL), the error was:

 socorro/unittest/external/es/base.py::IntegrationTestSuperSearch::test_get_with_too_many 

Traceback (most recent call last):

  File "/home/travis/build/mozilla-services/socorro/socorro/unittest/external/es/base.py", line 871, in health_check

    request_timeout=1

  File "/home/travis/virtualenv/python2.7.11/lib/python2.7/site-packages/elasticsearch/client/utils.py", line 69, in _wrapped

    return func(*args, params=params, **kwargs)

  File "/home/travis/virtualenv/python2.7.11/lib/python2.7/site-packages/elasticsearch/client/cluster.py", line 30, in health

    'health', index), params=params)

  File "/home/travis/virtualenv/python2.7.11/lib/python2.7/site-packages/elasticsearch/transport.py", line 307, in perform_request

    status, headers, data = connection.perform_request(method, url, params, body, ignore=ignore, timeout=timeout)

  File "/home/travis/virtualenv/python2.7.11/lib/python2.7/site-packages/elasticsearch/connection/http_requests.py", line 70, in perform_request

    raise ConnectionTimeout('TIMEOUT', str(e), e)

ConnectionTimeout: ConnectionTimeout caused by - ReadTimeout(HTTPConnectionPool(host='localhost', port=9200): Read timed out. (read timeout=1))
I don't think I've seen these with Circle, yet. Circle runs our tests with services in containers which is different than how Travis does.

So, maybe this will go away or reduce a lot between either the ES upgrade or switching to Circle.
(Assignee)

Updated

a year ago
Assignee: nobody → peterbe
(In reply to Will Kahn-Greene [:willkg] ET needinfo? me from comment #1)
> I don't think I've seen these with Circle, yet. Circle runs our tests with
> services in containers which is different than how Travis does.

I've seen these with Circle, too.

> So, maybe this will go away or reduce a lot between either the ES upgrade or
> switching to Circle.

I think this is still a possibility.

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.