Closed Bug 137707 Opened 18 years ago Closed 18 years ago

css background assigned to a COL is not shown

Categories

(Core :: Layout: Tables, defect)

x86
All
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 4510

People

(Reporter: bugzilla.mozilla.org, Assigned: karnaze)

Details

(Keywords: regression, testcase)

Attachments

(2 files)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1) Gecko/20020415

I assign some CSS formatting to a COL or COLGROUP element; either by defining a
clas or by setting the style attribute.

some properties like column width get assigned correctly but properties like
color, font etc. do not get assigned to the TDs in the Column.

compare behavior with MSIE 5 to see how it should work.
view in Mozilla and compare how it looks in MSIE 5
Boris Zbarsky in bug 122099:
See the CSS2 spec, http://www.w3.org/TR/REC-CSS2/tables.html#q4
Basically, the only styles applied to COL tags that can affect the way cells
look are border, background, width, and visibility.

Also see bug 915. 

Should be this bug marked as INVALID?
Looks mostly invalid *but* column background colours don't appear to shine
through (even in standards mode).

David Baron's test at
http://www.people.fas.harvard.edu/~dbaron/css/test/sec170501 also appears to
have regressed. Both work OK in Netscape 6.2
Yep, that's broken...  Over to tables
Assignee: attinasi → karnaze
Status: UNCONFIRMED → NEW
Component: Layout → HTMLTables
Ever confirmed: true
Keywords: regression, testcase
OS: Windows 2000 → All
QA Contact: petersen → amar
Summary: css styles assigned to a COL don't inherit to the TDs → css background assigned to a COL is not shown
Boris, if you claim that is broken when having a bug reference to bug 915,
please explain to the people how a table cell should inherit from a column. If
you come up with something reasonable I would be really happy. Up to now I
believe that the biggest flaw in the CSS2 table spec is exactly that there is no
way for this inheritance. 
This has nothing to do with bug 915.  There is no inheritance involved.  The
colframe should just be painting a background, which will then be visible
because the <tr> and <td> are transparent.  See the diagram at
http://www.w3.org/TR/REC-CSS2/tables.html#table-layers
bz thanks I hoped to learn soemthing new

*** This bug has been marked as a duplicate of 4510 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
verified.  Could we relnote the fact that backgrounds on <col> do not work?
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.