[Photon] back button in menu sub panels gets stuck in hover state

VERIFIED FIXED in Firefox 56

Status

()

Firefox
Toolbars and Customization
P1
normal
VERIFIED FIXED
2 months ago
20 days ago

People

(Reporter: Trevor Rowbotham, Assigned: Gijs)

Tracking

(Blocks: 2 bugs)

Trunk
Firefox 56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 verified)

Details

(Whiteboard: [photon-structure])

MozReview Requests

()

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
Windows 10, latest Nightly 64bit.

STR:
1) Open the menu.
2) Click on the Web Developer menu item.
3) Click the back button to return to the main menu.
4) Click on the Web Developer menu item again.

Notice that the back button in the sub panel is now stuck with the :hover styles. 

I have found that navigating to a different sub panel as well as mousedowning on the back button, then moving the mouse off the back button then releasing the mouse button (so as to cancel the click) resolves the issue.

Filing this in Firefox:General for now, though the underlying issue might be in Layout. Let me know if I can provide anymore information.
(Assignee)

Comment 1

2 months ago
Bizarre. Doesn't happen on OS X, only on Windows, AFAICT. Also once it's gone away, I can't re-reproduce by following the steps again.
Blocks: 1349210
Component: General → Toolbars and Customization
Summary: {Photon] back button in menu sub panels gets stuck in hover state → [Photon] back button in menu sub panels gets stuck in hover state
(Assignee)

Updated

2 months ago
Whiteboard: [photon-structure][triage]
(Assignee)

Updated

2 months ago
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Updated

2 months ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 56.2 - Jul 10
Flags: needinfo?(gijskruitbosch+bugs)
Whiteboard: [photon-structure][triage] → [photon-structure]
Comment hidden (mozreview-request)
(Assignee)

Comment 3

2 months ago
This was reasonably easy to fix, so I just went for it. :-)
Flags: qe-verify+
Priority: -- → P1
QA Contact: gwimberly

Comment 4

2 months ago
mozreview-review
Comment on attachment 8882679 [details]
Bug 1377139 - blur back button on use like other keyboard nav buttons,

https://reviewboard.mozilla.org/r/153744/#review159106

Simple, I like it! :)
Attachment #8882679 - Flags: review?(mdeboer) → review+

Comment 5

2 months ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1b0a878aade5
blur back button on use like other keyboard nav buttons, r=mikedeboer

Comment 6

2 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1b0a878aade5
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Checked on Linux as well just to be sure. Looks fixed on all counts to me. Marking Verified.
Status: RESOLVED → VERIFIED
status-firefox56: fixed → verified
Flags: qe-verify+
Blocks: 1387512
You need to log in before you can comment on or make changes to this bug.