Closed Bug 1377221 Opened 2 years ago Closed 2 years ago

Raw talos data contains "NaN" values

Categories

(Testing :: Talos, enhancement)

enhancement
Not set

Tracking

(firefox56 fixed)

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: wlach, Assigned: wlach)

Details

Attachments

(2 files)

Because we're using the python json library to serialize the talos replicate data, the replicates can contain "NaN" which are not currently supported by all json parsers. For example:

http://mozilla-releng-blobs.s3.amazonaws.com/blobs/Firefox/sha512/f5a7a215b56f9e8d95562a73de089e1747c48d9f64ae086a91abfa11baf20c295f07833eeecb9f2006682f4c9ce8b0240d4eebc5035936093001c41645423137

The problem is this line:

http://searchfox.org/mozilla-central/rev/152c0296f8a10f81185ee88dfb4114ec3882b4c6/testing/talos/talos/output.py#199

We should be able to fix this by using the simplejson library to serialize stuff and using the ignore_nan option:

https://stackoverflow.com/questions/6601812/sending-nan-in-json
Comment on attachment 8882307 [details]
Bug 1377221 - Use ignore_nan when dumping talos json blobs

https://reviewboard.mozilla.org/r/153402/#review158598

great find, and simple fix.
Attachment #8882307 - Flags: review?(jmaher) → review+
Comment on attachment 8882332 [details]
Bug 1377221 - Add simplejson dependency to talos

https://reviewboard.mozilla.org/r/153410/#review158716
Attachment #8882332 - Flags: review?(jmaher) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e81dc885680a
Add simplejson dependency to talos r=jmaher
https://hg.mozilla.org/integration/autoland/rev/9d061aaec7aa
Use ignore_nan when dumping talos json blobs r=jmaher
https://hg.mozilla.org/mozilla-central/rev/e81dc885680a
https://hg.mozilla.org/mozilla-central/rev/9d061aaec7aa
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.